Visit Our UNIX and Linux User Community


performance problem


 
Thread Tools Search this Thread
Top Forums UNIX for Advanced & Expert Users performance problem
# 1  
Old 03-05-2002
performance problem

Hello,

I have a mail server (sendmail) with SUNOS 5.5.1. Just recently it began to respond very slowly.

I used vmstat to check the performance data. Only interupt, system call and CPU context swiching are relatively high. Other statistics are normal, especially CPU utilization are very low.

How I can improve those high statistics if they cause the problems.



Thanks,

Cao Ai
# 2  
Old 03-05-2002
Is this server only running Sendmail? If so, then check to see if you have an increased volume of email that it is handling.

If you save the messages files or have stats on how much mail it handles, please check to see how many messages per week. If spammers have started hitting your system, this could be the only problem you are having.

You can check that you are not an open relay for spammers to use (www.abuse.net)

Next, do you have sar or any monitoring running? What is the version of Sendmail? Is it set up to use DNS? Has DNS recently changed (if sendmail is waiting on DNS, it can slow down your system as messages are not flowing as quickly waiting on timeouts from a DNS request).

Post output from % /usr/lib/sendmail -d0.1 -bt < /dev/null
(change company info as appropriate).
thehoghunter
# 3  
Old 03-06-2002
Hi,

Thank you very much.

The server only runs sendmail, and the volume of mail is relatively small. Other situations(spam and DNS) are all seemingly OK.

Here I post information you want and output of vmstat:

> /usr/lib/sendmail -d0.1 -bt </dev/null
Version 8.9.2
Compiled with: MAP_REGEX LOG MATCHGECOS MIME7TO8 MIME8TO7 NAMED_BIND
NDBM NETINET NETUNIX NEWDB NIS NISPLUS QUEUE SCANF SMTP USERDB
XDEBUG

============ SYSTEM IDENTITY (after readcf) ============
(short domain name) $w = mail
(canonical domain name) $j = mail.cgac.com.cn
(subdomain name) $m = cgac.com.cn
(node name) $k = mail
========================================================

ADDRESS TEST MODE (ruleset 3 NOT automatically invoked)
Enter <ruleset> <address>
>vmstat 5

procs memory page disk faults cpu
r b w swap free re mf pi po fr de sr f0 s0 -- -- in sy cs us sy id
0 0 0 150264 75248 0 0 0 0 0 0 0 0 10 0 0 271 204 217 0 1 99
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 218 205 215 0 0 99
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 216 203 214 0 0 100
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 215 204 212 0 0 100
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 216 205 214 0 0 99
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 216 203 215 0 0 100
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 218 204 213 0 0 100
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 213 203 214 0 0 99
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 217 204 215 0 0 100
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 217 204 215 0 0 100
0 0 0 150264 75248 0 0 0 0 0 0 0 0 0 0 0 211 203 215 0 0 100
0 0 0 150096 75080 0 438 0 0 0 0 0 0 0 0 0 217 931 249 8 8 84
0 0 0 149424 74400 0 4025 0 0 0 0 0 0 0 0 0 219 4438 450 39 61 0
0 0 0 149016 74384 0 4026 0 0 0 0 0 0 0 0 0 214 4446 454 41 59 0
0 0 0 149992 74960 0 1406 0 0 0 0 0 0 7 0 0 267 1768 323 18 23 59
0 0 0 150712 75456 0 0 0 0 0 0 0 0 0 0 0 215 205 215 0 0 100
0 0 0 150712 75456 0 0 0 0 0 0 0 0 0 0 0 213 203 216 0 0 100
0 0 0 150712 75456 0 0 0 0 0 0 0 0 0 0 0 216 203 215 0 0 100
0 0 0 150008 74488 0 0 0 0 0 0 0 0 0 0 0 220 204 214 0 0 99
0 0 0 149728 74248 0 21 0 0 0 0 0 0 0 0 0 214 257 220 1 0 99
0 0 0 149632 74200 0 13 0 0 0 0 0 0 0 0 0 219 219 217 0 1 99
0 0 0 149280 74040 0 0 0 0 0 0 0 0 0 0 0 215 203 214 0 0 100

I have no sar and other monitoring tools. The server supports telnet and ftp services(which are all got very slow response now). I have minimize the number of process, including stopping Openwindows. Following is the process status:

# ps -ef
UID PID PPID C STIME TTY TIME CMD
root 0 0 0 Mar 05 ? 0:00 sched
root 1 0 0 Mar 05 ? 0:00 /etc/init -
root 2 0 0 Mar 05 ? 0:00 pageout
root 3 0 0 Mar 05 ? 0:27 fsflush
root 458 1 0 Mar 05 ? 0:00 /usr/lib/saf/sac -t 300
root 4575 190 0 14:42:15 ? 0:00 /usr/lib/sendmail -bd -q1h
root 111 1 0 Mar 05 ? 0:00 /usr/sbin/keyserv
root 157 1 0 Mar 05 ? 0:00 /usr/sbin/syslogd
root 125 1 0 Mar 05 ? 0:00 /usr/sbin/in.named
root 45 1 0 Mar 05 ? 0:00 /opt/netra/SUNWi150/sysctld -I -h 600
root 129 1 0 Mar 05 ? 0:02 /usr/sbin/inetd -s
root 117 1 0 Mar 05 ? 0:00 /usr/sbin/kerbd
root 132 1 0 Mar 05 ? 0:00 /usr/lib/nfs/statd
root 134 1 0 Mar 05 ? 0:00 /usr/lib/nfs/lockd
root 153 1 0 Mar 05 ? 0:00 /usr/lib/autofs/automountd
root 205 1 0 Mar 05 ? 0:00 /usr/sbin/vold
root 170 1 0 Mar 05 ? 0:02 /usr/sbin/nscd
root 4576 190 0 14:42:20 ? 0:00 /usr/lib/sendmail -bd -q1h
root 190 1 0 Mar 05 ? 0:01 /usr/lib/sendmail -bd -q1h
root 200 1 0 Mar 05 ? 0:00 /usr/lib/utmpd
root 210 1 0 Mar 05 ? 0:00 /opt/netra/SUNWnetra/bin/httpd -f /etc/opt/netraf
root 275 273 0 Mar 05 ? 0:00 /usr/local/netscape/nse-home/admserv/ns-admin -da
root 459 1 0 Mar 05 console 0:00 /usr/lib/saf/ttymon -g -h -p mail console login:c
root 4569 129 0 14:41:03 ? 0:00 in.telnetd
root 272 1 0 Mar 05 ? 0:00 /usr/local/netscape/nse-home/admserv/ns-admin -da
root 261 1 0 Mar 05 ? 0:00 /opt/SUNWipx/bin/NWnvtd
root 273 1 0 Mar 05 ? 0:00 /usr/local/netscape/nse-home/admserv/ns-admin -da
root 465 458 0 Mar 05 ? 0:00 /usr/lib/saf/ttymon
nobody 780 1 0 16:02:32 ? 0:00 ./ns-httpd -d /usr/local/netscape/nse-home/httpsg
root 4582 4572 0 14:42:39 pts/0 0:00 sh
root 4566 190 0 14:38:24 ? 0:00 /usr/lib/sendmail -bd -q1h
caoai 4572 4569 0 14:41:21 pts/0 0:00 -csh
root 4583 190 0 14:42:47 ? 0:00 /usr/lib/sendmail -bd -q1h
root 4567 4566 8 14:39:58 ? 0:16 /usr/lib/sendmail -bd -q1h
root 4584 4582 1 14:42:59 pts/0 0:00 ps -ef


I wonder if there is any strange processe in the system.

Best Regards


Cao Ai
# 4  
Old 03-06-2002
You can still use the "top" which shows
which process is using the cpu time.

--Jagadeesh
# 5  
Old 03-06-2002
Thanks.

I don't have 'top' in my system.

Cao Ai
# 6  
Old 03-06-2002
Try to download it from http://www.sunfreeware.com Smilie

EDIT: Fixed Link - LivinFree

Last edited by LivinFree; 03-06-2002 at 09:10 AM..

Previous Thread | Next Thread
Test Your Knowledge in Computers #11
Difficulty: Medium
IBM chose the name System/360 (or S/360) because it was one of the first computers to focus on graphics processing.
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Performance problem in Shell Script

Hi, I am Shell script beginner. I wrote a shell programming that will take each line of a file1 and search for it in another file2 and give me the output of the lines that do not exist in the file2. I wrote it using do while nested loop but the problem here is its running for ever . Is there... (12 Replies)
Discussion started by: sakthisivi
12 Replies

2. UNIX for Advanced & Expert Users

Performance problem with bidirectional nc

Working on a simple, half duplex network diagnostic that will run anywhere using nc and dd. Performance is symmetrical with sink and source nc processes open as a server: nc -vkl 5000 > /dev/null & cat /dev/zero | nc -vkl 5001 & With this on the client: nc host0 5001 | dd of=/dev/null... (0 Replies)
Discussion started by: netdrx
0 Replies

3. HP-UX

Performance problem - waiting on cache

My server is running HP-UX 11.23 and one Oracle database. The server has 8 CPUs and is mostly idle all the time. Buffer cache is set to 10%min/max with 5GB memory on the server. I have a user complaining that a batch process is all of a sudden taking a long time to finish. The DBA gave me the... (13 Replies)
Discussion started by: keelba
13 Replies

4. Red Hat

Disk performance problem on login

Running CentOS 5.5: I've come across a relatively recent problem, where in the last 2 months or so, the root disk goes to 99% utilization for about 20 seconds when a user logs in. This occurs whether a user logs in locally or via ssh. I have tried using lsof to track down the process that is... (5 Replies)
Discussion started by: dangral
5 Replies

5. Linux

Help in monitoring performance problem in Linux

hello, i'm having some performance problem on one of my linux machines and i hope someone will be able to help me analyzing the problem. machine info: Linux fedora, cpu x 4 cores of 1.6Ghz, 8G memory, 8G swap. i've enabled sar on my machine and created a graph using ksar utility for... (15 Replies)
Discussion started by: levic
15 Replies

6. Emergency UNIX and Linux Support

VPN performance problem

This is a weird problem I've been butting my head against for days now... I have two OpenVPN servers set up with identical configurations except for the keys. One of them is hosted in a datacenter with a large backbone, the other is hosted on my home server's limited residential internet. One... (9 Replies)
Discussion started by: Corona688
9 Replies

7. UNIX for Dummies Questions & Answers

Network performance problem

I have a Teradata Machine, using MP-RAS Unix, with a 1000 Intel Ethernet card and a Cisco switch. If I configure the ethernet card and the switch to auto, so they negotiate to 1000, or configure the ethernet card and switch manually to 1000Full or 100Full, the velocity is very very low. Only... (2 Replies)
Discussion started by: cuatrodos
2 Replies

8. Solaris

Performance problem

Hi All, There is a virtual user "ecoouk" which logs on to the server and runs some scripts. I want to know how much server performance can I gain if I put off all the scripts run by this user. Please tell me how to analyse how much resources a specific user is using. Regards, Abhishek (3 Replies)
Discussion started by: max29583
3 Replies

9. UNIX for Advanced & Expert Users

AIX server performance problem!

Hello, I have a performance problem on an AIX box. I'm not sure what is causing this and hoping someone may have suggestions. Currently I'm noticing that cpu's are waiting while the box is in a idle state. I checked the disks and none of them are at 100%. If they were then I would understand... (3 Replies)
Discussion started by: ctcuser
3 Replies

Featured Tech Videos