Visit Our UNIX and Linux User Community


ATI Radeon HD 3200, Compiz, FreeBSD8.0-RC2, White screen


 
Thread Tools Search this Thread
Top Forums UNIX for Advanced & Expert Users ATI Radeon HD 3200, Compiz, FreeBSD8.0-RC2, White screen
# 1  
Old 11-10-2009
ATI Radeon HD 3200, Compiz, FreeBSD8.0-RC2, White screen

The issue I'm having (after some effort) is that while compiz starts fine and functions (I can use the cube, expo, key bindings all good) all desktops are white. I can't see any of my windows, backgrounds, or menus. I am using FreeBSD 8 with no custom kernel options or otherwise interesting configuration. I have installed x11-drivers/xf86-video-radeonhd per the handbook. I also tried x11-drivers/xf86-video-radeonhd-devel . I'm aware this issue is all over the internet but none of the solutions I saw worked for me. I have xorg.conf configured for Driver "radeonhd" and it starts up fine. kldstat reports both drm and radeon are running. I tried an option I saw online; Option "AIGLX" "true" but it caused an intermittent hard lock that (maybe?) is related to DRI. I am attaching all relevant files and would appreciate any and all help ! thank you !!!

Code:
$ uname -mrs
FreeBSD 8.0-RC2 

$ dmesg | grep drm
drm0: <ATI Radeon HD 3200 Graphics> on vgapci0
info: [drm] MSI enabled 1 message(s)
vgapci0: child drm0 requested pci_enable_busmaster
info: [drm] Initialized radeon 1.31.0 20080613
info: [drm] Setting GART location based on new memory map
info: [drm] Loading RS780/RS880 Microcode
info: [drm] Resetting GPU
info: [drm] writeback test succeeded in 1 usecs
drm0: [ITHREAD]
info: [drm] Resetting GPU

$ kldstat | grep drm
38    1 0xffffffff8139d000 11397    drm.ko

$ kldstat | grep radeon
37    1 0xffffffff81338000 6485f    radeon.ko

$ pciconf -l | grep vga
vgapci0@pci0:1:5:0:    class=0x030000 card=0x82f11043 chip=0x96101002 rev=0x00 hdr=0x00

$ LIBGL_ALWAYS_INDIRECT=1 compiz --replace ccp

(see screenshots)

------

On an unrelated note I can't seem to upload attachments anywhere from this FreeBSD system (facebook, my e-mail service, this site). The uploads act like they're going but never complete. For that reason here is a link to the screenshots I took:
Index of /Photos

And here is the entire xorg.conf:

Code:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/local/lib/xorg/modules"
    FontPath     "/usr/local/lib/X11/fonts/misc/"
    FontPath     "/usr/local/lib/X11/fonts/TTF/"
    FontPath     "/usr/local/lib/X11/fonts/OTF"
    FontPath     "/usr/local/lib/X11/fonts/Type1/"
    FontPath     "/usr/local/lib/X11/fonts/100dpi/"
    FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
    Load  "extmod"
    Load  "record"
    Load  "dbe"
    Load  "glx"
        Load  "drm"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/sysmouse"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    #DisplaySize      580   320    # mm
    Identifier   "Monitor0"
    VendorName   "WDE"
    ModelName    "SK-26H590D"
    HorizSync    30.0 - 49.0
    VertRefresh  50.0 - 75.0
    Option        "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        Option     "NoAccel"                # [<bool>]
        #Option     "SWcursor"               # [<bool>]
        #Option     "Dac6Bit"                # [<bool>]
        #Option     "Dac8Bit"                # [<bool>]
        #Option     "BusType"                # [<str>]
        #Option     "CPPIOMode"              # [<bool>]
        #Option     "CPusecTimeout"          # <i>
        #Option     "AGPMode"                # <i>
        #Option     "AGPFastWrite"           # [<bool>]
        #Option     "AGPSize"                # <i>
        #Option     "GARTSize"               # <i>
        #Option     "RingSize"               # <i>
        #Option     "BufferSize"             # <i>
        #Option     "EnableDepthMoves"       # [<bool>]
        #Option     "EnablePageFlip"         # [<bool>]
        #Option     "NoBackBuffer"           # [<bool>]
        #Option     "DMAForXv"               # [<bool>]
        #Option     "FBTexPercent"           # <i>
        #Option     "DepthBits"              # <i>
        #Option     "PCIAPERSize"            # <i>
        #Option     "AccelDFS"               # [<bool>]
        #Option     "IgnoreEDID"             # [<bool>]
        #Option     "DisplayPriority"        # [<str>]
        #Option     "PanelSize"              # [<str>]
        #Option     "ForceMinDotClock"       # <freq>
        #Option     "ColorTiling"            # [<bool>]
        #Option     "VideoKey"               # <i>
        #Option     "RageTheatreCrystal"     # <i>
        #Option     "RageTheatreTunerPort"     # <i>
        #Option     "RageTheatreCompositePort"     # <i>
        #Option     "RageTheatreSVideoPort"     # <i>
        #Option     "TunerType"              # <i>
        #Option     "RageTheatreMicrocPath"     # <str>
        #Option     "RageTheatreMicrocType"     # <str>
        #Option     "ScalerWidth"            # <i>
        #Option     "RenderAccel"            # [<bool>]
        #Option     "SubPixelOrder"          # [<str>]
        #Option     "ShowCache"              # [<bool>]
        #Option     "DynamicClocks"          # [<bool>]
        #Option     "VGAAccess"              # [<bool>]
        #Option     "ReverseDDC"             # [<bool>]
        #Option     "LVDSProbePLL"           # [<bool>]
        #Option     "AccelMethod"            # <str>
        #Option     "DRI"                    # [<bool>]
        #Option     "ConnectorTable"         # <str>
        #Option     "DefaultConnectorTable"     # [<bool>]
        #Option     "DefaultTMDSPLL"         # [<bool>]
        #Option     "TVDACLoadDetect"        # [<bool>]
        #Option     "ForceTVOut"             # [<bool>]
        #Option     "TVStandard"             # <str>
        #Option     "IgnoreLidStatus"        # [<bool>]
        #Option     "DefaultTVDACAdj"        # [<bool>]
        #Option     "Int10"                  # [<bool>]
        #Option     "EXAVSync"               # [<bool>]
        #Option     "ATOMTVOut"              # [<bool>]
        #Option     "R4xxATOM"               # [<bool>]
    Identifier  "Card0"
    Driver      "radeonhd"
    VendorName  "ATI Technologies Inc"
    BoardName   "Radeon HD 3200 Graphics"
    BusID       "PCI:1:5:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
        DefaultDepth    24
        Option         "AddARGBGLXVisuals" "True"
        SubSection "Display"
        Viewport   0 0
        Depth    24 
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth    24 
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth    24 
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth    24 
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth    24 
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "DRI"
    Mode 0666
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection



Thanks for looking and any ideas would be greatly appreciated !!

Last edited by pludi; 11-11-2009 at 07:11 AM.. Reason: code tags, please...

Previous Thread | Next Thread
Test Your Knowledge in Computers #728
Difficulty: Medium
Bjarne Stroustrup was awarded the Computer Pioneer Award for pioneering C++.
True or False?

6 More Discussions You Might Find Interesting

1. Hardware

ATI Radeon HD 7450 DP Linux driver

I'm looking for Linux driver for ATI Radeon HD 7450 graphics card. The OS I'm using is RHEL5.7 server. The desktop is HP compaq elite 8300 SFF. Couldn't find it in hp.com support website. Downloaded AMD Catalyst 13.1 Proprietary Linux x86 Display Driver (file size is 109MB) from... (1 Reply)
Discussion started by: joker_789us
1 Replies

2. Red Hat

Install PCI ATI radeon 7000

its an old ati video card ( never use) added to my server.... Running Centos 6.3 now I can only log in terminal and I can not log in X server.... I try to startX... cant getting goint I got this errors when I run startx Failed to load module "ati" ( module does not exist, 0) Failed to load... (0 Replies)
Discussion started by: golpemortal
0 Replies

3. Slackware

compiz-fusion in slackware 13.37?

Has anyone successful runned compiz-fusion in newer slackware version? And how if I may ask? :wall: (0 Replies)
Discussion started by: darkman_hr
0 Replies

4. Linux

Compiz Config File

Hi All I am using Fedora8 with KDE and i am trying to find the location of the file compiz is using This is becasue i am looking for a way to write a scritp to run acorss people home space to see if the have compiz enabled any help would be great thanks Adam (0 Replies)
Discussion started by: ab52
0 Replies

5. UNIX Desktop Questions & Answers

X-window+radeon 9700pro

i can`t configure resolution on my screen:( the resolution is 400*600. but i want more, and when i choose another resolution(1024*768) X don`t want to start? what shall i do? (6 Replies)
Discussion started by: crush
6 Replies

6. UNIX for Dummies Questions & Answers

Anyone know if ATI RADEON 7500 will work under RH 7.2?

Anyone know if ATI ALL-IN-WONDER RADEON 7500 will work under RH 7.2? All I see listed on the RD HCL page is the ATI ALL-IN-WONDER PRO. Thanks, Chuck (3 Replies)
Discussion started by: 98_1LE
3 Replies

Featured Tech Videos