Visit Our UNIX and Linux User Community


Compiling samba 3.0.27a under AIX

 
Thread Tools Search this Thread
Special Forums UNIX and Linux Applications Compiling samba 3.0.27a under AIX
# 1  
Old 12-03-2007
Compiling samba 3.0.27a under AIX

I try to compile Samba 3.0.27a under AIX with LDAP and KErberos.
The configure work fine:
CFLAGS:
-I/opt/pware/include -I/opt/pware/lib/ -I/opt/pware/open_ldap_exec/lib/ -I/software/samba/oldap/usr/lib -I/software/samba/oldap/usr/include

./configure --prefix=/opt/pware/samba/3.0.27a --with-acl-support --with-ads --with-winbind --with-ldap --with-krb5

But when i start make I get the following errors:
passdb/pdb_ldap.c: In function 'ldapsam_get_new_rid':
passdb/pdb_ldap.c:4459: error: incompatible types in assignment
passdb/pdb_ldap.c: In function 'pdb_init_ldapsam':
passdb/pdb_ldap.c:5654: error: incompatible types in assignment
The following command failed:
gcc -I. -I/software/samba/samba_327a/source -I/opt/pware/include -I/opt/pware/include -I/opt/pware/lib/ -I/opt/pware/open_ldap_exec/lib/ -I/software/samba/oldap/usr/lib -I/software/samba/oldap/usr/include -R/opt/pware/include -R/opt/pware/lib/ -R/opt/pware/open_ldap_exec/lib/ -R/software/samba/oldap/usr/lib -R/software/samba/oldap/usr/include -D_SAMBA_BUILD_=3 -I/software/samba/samba_327a/source/iniparser/src -Iinclude -I./include -I. -I. -I./lib/replace -I./lib/talloc -I./tdb/include -I./libaddns -I./librpc -DHAVE_CONFIG_H -I/opt/pware/include -I/opt/pware/berkdb/include -I/opt/pware/berkdb/bin -DLDAP_DEPRECATED -I/software/samba/samba_327a/source/lib -D_SAMBA_BUILD_=3 -O2 -c passdb/pdb_ldap.c -o passdb/pdb_ldap.o
make: 1254-004 The error code from the last command is 1.

I have googled for these errors but I have found no solution.
Can anyone help me please?
Benedikt
# 2  
Old 12-06-2007
Solved

I don't know what exactly I have done.
But when I tried to compile the Xth time make did it.
Best Regards
Benedikt

Previous Thread | Next Thread
Test Your Knowledge in Computers #558
Difficulty: Medium
The term bug was popularized by Grace Hopper in 1947 while working on a Mark II Computer at a US Navy research lab when a moth was stuck in the computer.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Samba 3.6 on AIX 7.1 - Windows 10 Access to AIX file shares using Active Directory authentication

I am running AIX 7.1 and currently we have samba 3.6.25 installed on the server. As it stands some AIX folders are shared that can be accessed by certain Windows users. The problem is that since Windows 10 the guest feature no longer works so users have to manually type in their Windows login/pwd... (14 Replies)
Discussion started by: linuxsnake
14 Replies

2. UNIX for Beginners Questions & Answers

Compiling Samba 4.4.5

I am running Fedora V21 and had their default Samba installed. But I wanted to put up a PDC with ADS, so I uninstalled samba and down loaded the Samba 4.4.5 source along with the Kerberos devel kit etc. I then configured and compiled etc and it indicated it was successful. But I can't load the... (0 Replies)
Discussion started by: griffinmt
0 Replies

3. AIX

New to AIX need help Installing/Upgrading Samba on AIX 7.1?

Hello, I am trying to update Samba on my AIX 7.1 system as there is an issues with it, the smbd process coredumps and I have had no luck figuring it out why. My approach is to try to re-install a newer samba and I have found the latest 3.x package for samba in ppc.rpm format at perlz.org ... (6 Replies)
Discussion started by: c3rb3rus
6 Replies

4. Solaris

Compiling Error in Samba 3.4.1 on Solaris 10

Hi all, I am getting the following error While installing Samba 3.4.1 on Solaris 10. #./autogen.sh ./autogen.sh : autoheader : not found ./autogen.sh : test : argument expected Please help me as I am in a critical state of the project. Warm regards, Sathya (10 Replies)
Discussion started by: sathya47
10 Replies

5. UNIX for Dummies Questions & Answers

Compiling samba problem

People i download the lastest version of samba i`am tryng to compile it in a solaris 9 i'm reading the how to of samba, i am in the first step making the autogen.sh but show me this when i do ./autogen.sh ./autogen.sh: running script/mkversion.sh ./script/mkversion.sh: 'include/version.h'... (0 Replies)
Discussion started by: enkei17
0 Replies

6. Solaris

Problem compiling Samba 3.5.1 on Solaris 10 with gcc (3.4.6)

I'm getting this error when 'Linking shared library bin/libtalloc.so.2'... anyone know what's up here? Using CFLAGS = -O -I. -I/source/samba-3.5.1/source3 -I/source/samba-3.5.1/source3/../lib/popt -I/source/samba-3.5.1/source3/iniparser/src -Iinclude -I./include -I. -I. -I./../lib/replace... (6 Replies)
Discussion started by: son_t
6 Replies

7. UNIX for Advanced & Expert Users

Compiling Samba from Source on AIX, Active Directory, LDAP, Kerberos

Hello, I asked this question in the AIX subforum but never received an answer, probably because the AIX forum is not that heavily trafficked. Anyway, here it is.. I have never had any issues like this when compiling applications from source. When I try to compile samba-3.5.0pre2, configure runs... (9 Replies)
Discussion started by: raidzero
9 Replies

8. AIX

Compiling samba from source in AIX 5.3

Hello all. I have never had any issues like this when compiling applications from source. When I try to compile samba-3.5.0pre2, configure runs with no issues, but when the time comes to make, this happens: make: make 1254-025 There must be an existing description file or specify a target. ... (4 Replies)
Discussion started by: raidzero
4 Replies

9. Solaris

Samba Compiling questions

OS: Solaris 10 I downloaded a binary from samba.org (3.0.24) I extracted the file and ran the following command: # ./configure --prefix=/usr/sfw --with-configdir=/etc/sfw --with-winbind Now I am trying to understand the compile process but I can't find many answers online ... (10 Replies)
Discussion started by: Keepcase
10 Replies

10. AIX

Compiling samba 3.0.27a under AIX

Compiling samba 3.0.27a under AIX I try to compile Samba 3.0.27a under AIX with LDAP and KErberos. The configure work fine: CFLAGS: -I/opt/pware/include -I/opt/pware/lib/ -I/opt/pware/open_ldap_exec/lib/ -I/software/samba/oldap/usr/lib -I/software/samba/oldap/usr/include ./configure... (2 Replies)
Discussion started by: BenediktS
2 Replies

Featured Tech Videos