net_protocol_lookup(9F) 				   Kernel Functions for Drivers 				   net_protocol_lookup(9F)

NAME
net_protocol_lookup - locate an implementation of a network layer protocol SYNOPSIS
#include <sys/neti.h> net_data_t net_protocol_lookup(netid_t id, const char *protocol); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
id network instance identifier. family name of the network protocol to find. DESCRIPTION
The net_protocol_lookup() function attempts to locate a data structure that defines what capabilities it is exporting through this inter- face. The value returned by this call is guaranteed to be valid until it is passed into a call to net_protocol_release(9F), after which it should no longer be treated as valid. The protocol must be a registered name of a network protocol that has been registered. The symbols NHF_INET and NHF_INET6 should be passed to net_protocol_lookup() as the protocol name to gain access to either IPv4 or IPv6 respectively. RETURN VALUES
The net_protocol_lookup() function returns NULL if it does not find any knowledge about the network protocol referenced. Otherwise, it returns a value that can be used with other calls in this framework. CONTEXT
The net_protocol_lookup() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_protocol_release(9F), attributes(5) SunOS 5.11 1 May 2008 net_protocol_lookup(9F)