Visit Our UNIX and Linux User Community


Networking with Hub, & Sol 10 Problem


 
Thread Tools Search this Thread
Operating Systems Solaris Networking with Hub, & Sol 10 Problem
# 1  
Old 10-10-2007
Networking with Hub, & Sol 10 Problem

Unable to Ping network nodes

Currently have two Solaris 10 servers connected via a dumb Hub. I'm unable to ping either box but they can ping themselves. I have double checked physical connections and the following files;

/etc/hosts - verified that all devices are listed correctly
/etc/netmasks - Verified that network and netmask was correct
/etc/defaltrouter - deleted file as there is no router
/etc/resolve.conf - xxx.xxx.xxx.xxx listed as name server
/etc/nsswitch - removed dns from "host" line
/etc/inet/ipnodes - only local IP listed

Verified that correct NIC is enabled with ifconfig -a

This is an internal Class-C network with no intentions to connect externally. I have no DNS server nor router and just want to communicate with between these two servers, and a windows box eventually.

Any assistance is appreciated, New to SOL 10
# 2  
Old 10-10-2007
Can you post the "ifconfig -a" of both boxes?

Should say something like

Code:
$ ifconfig hme0
hme0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
        inet a.b.c.d netmask ffffff00 broadcast a.b.c.255

Do you have lights on your hub?

Are you using two drop cables, and not cross-over cables?

If you have a cross over, try plugging from one machine to another?

Are you using the "uplink" port on your hub? (often this is a cross over)
# 3  
Old 10-10-2007
lo0 flags=2001000849 <up,loopback, RUNNING, MULTICAST, IPv4, VIRTUAL> mtu 8232 index 1
inet 127.0.0.1 netmask ff000000
ce0 flags = 1000803 <up, BROADCAST,MULTICAST, Ipv4 1500 index 2
inet 192.168.161.239 netmask ffffff00 broadcast 192.168.161.255
ether 0:3:ba:.......................

Other box is identical except for the <inet 192.168.161.238........




Lights are on on the HUB
2 Drop cables are being used
I am not using and uplink

Last edited by pham; 10-10-2007 at 01:20 PM..
# 4  
Old 10-10-2007
Does the hub have any lights that flash when traffic occurs?

Try each machine plugged in by itself to the hub and see if the lights flash.

Does the hub have power connected, switched on, any other configuration switches?
# 5  
Old 10-10-2007
I also attempted to connect server to server via crossover and still no progress

The Hub has lights but no traffic/flashing lights is occuring
Plugged in each server by themselves, still no flashing lights
The HUB does have power and is switched on, The only switch is the uplink/normal toggle switch. (currently set for normal)
The Hub is a 8-port Netgear DS108

Previous Thread | Next Thread
Test Your Knowledge in Computers #281
Difficulty: Easy
A hypervisor or virtual machine monitor (VMM) is a computer software, firmware or hardware that creates and runs virtual private networks.
True or False?

10 More Discussions You Might Find Interesting

1. Proxy Server

Linux Networking - VLANs & Multiple IP's

In a "typical" data centre environment (telco, financial services etc), would a Linux OS typically have one IP address connected to one VLAN or would it have many IPs and/or VLANs. I say "Linux OS" as I'm referring to an instance of the OS not necessarily a Host or server. Think Linux OS = VM in a... (9 Replies)
Discussion started by: PCB
9 Replies

2. Solaris

JASS - upgrading from Sol 9 to Sol 10

Do I need to reinstall/rerun JASS after upgrading from Sol9 to Sol10? Just wondered if the upgrade procedure overwrote any of the settings etc? (0 Replies)
Discussion started by: psychocandy
0 Replies

3. IP Networking

networking problem in virtual machine

Hi, I am running scientific linux guest on ubuntu host. The problem is that the guest machine doesn't have any ip except from the loopback. I want that the guest OS will be in the same local network of the host and not part of internal network that virtualbox create. In other words I... (1 Reply)
Discussion started by: programAngel
1 Replies

4. UNIX for Dummies Questions & Answers

problem of networking in centos

Hello, I am using dual boot of linux, one is ubuntu and the other is one is centos. I have three NIC's and only one of them connected with cable. The thing is that when I boot from the ubuntu, it does recognize it and I am connected to the Internet. When I boot from the centos I am not... (6 Replies)
Discussion started by: programAngel
6 Replies

5. Solaris

Solaris networking problem

e1000g0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2 inet 10.13.157.127 netmask ffffffc0 broadcast 10.135.151.191 ether 0:14:4f:a0:e3:3a e1000g1: flags=1000803<UP,BROADCAST,MULTICAST,IPv4> mtu 1500 index 8 inet 10.13.157.227 netmask ffffffc0... (3 Replies)
Discussion started by: sunnybee
3 Replies

6. UNIX for Advanced & Expert Users

luupgrade: Sol 8 -> Sol 10 u7 (5/09)

Greetings Forumers! I ran into an issue after running luupgrade on v880 running Solaris 8. I want to upgrade to Solaris 10. When I rebooted the system I noticed the file systems listed as such: # df -h Filesystem size used avail capacity Mounted on /dev/dsk/c1t1d0s0 ... (2 Replies)
Discussion started by: bluescreen
2 Replies

7. What is on Your Mind?

Career in Networking & Network Security

Hii i want to make career in networking and i m new in this field could u plz help me what should i do (2 Replies)
Discussion started by: pawan_kumar
2 Replies

8. UNIX for Advanced & Expert Users

Networking Problem

Hi all, When I tried to restart the networking daemon, it stated this error: MyServer:/etc/init.d# ./networking restart Reconfiguring network interfaces...RTNETLINK answers: Network is unreachable run-parts: /etc/network/if-up.d/route exited with return code 2 done. Please note that I... (2 Replies)
Discussion started by: mjdousti
2 Replies

9. UNIX for Dummies Questions & Answers

Networking unix & windows

I have very basic question: I have 2 windows sytem & 1 Unix system & wanted to put all three system into one network to each other. what kind of other hardware I need? like cable , router? can anybody tell me the configuration? like how to connect to external hardware to put into network? ... (9 Replies)
Discussion started by: kar1
9 Replies

10. IP Networking

Networking problem ?

Hi, How to check whether a port is working properly or not ? I am getting a Error message Could not open connection to the host, on port 23: Connect failed. Thanks !! (1 Reply)
Discussion started by: dreams5617
1 Replies

Featured Tech Videos