UnsatisfiedLinkError libLicense.so: ld.so.1: java: fatal: libssl.so.0.9.8: open faile


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
UnsatisfiedLinkError libLicense.so: ld.so.1: java: fatal: libssl.so.0.9.8: open faile

Hi Guys,
Please help me out. I am new to solaris. I am using solaris 10
___________________________________________________________
public class Filecheck{

public static void main(String[] args) {
System.out.println("LD_LIBRARY_PATH is : "+System.getProperty("java.library.path"));
System.loadLibrary("License");
}
____________________________________________________________

When i execute the java program above i get the following error.

LD_LIBRARY_PATH is : /usr/jdk/instances/jdk1.5.0/jre/lib/sparc/server:/usr/jdk/instances/jdk1.5.0/jre/lib/sparc:/usr/jdk/instances/jdk1.5.0/jre/../lib/sparc::/export/home/emsadmin/joshua/:/usr/lib
Exception in thread "main" java.lang.UnsatisfiedLinkError: /export/home/emsadmin/joshua/libLicense.so: ld.so.1: java: fatal: libssl.so.0.9.8: open failed: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
at java.lang.Runtime.loadLibrary0(Runtime.java:822)
at java.lang.System.loadLibrary(System.java:992)
at Filecheck.main(Filecheck.java:10)

I have set my LD_LIBRARY_PATH variable which points correctly to the library file "libLicense.so".
It seems the library libssl.so.0.9.8 is not present.
When i checked in the directory /usr/local/ssl/lib i could see the file "libssl.so.0.9.7" but the file "libssl.so.0.9.8" is not present.

What might be the reason. Where can i get the library "libssl.so.0.9.8". Or can i make my program use the library libssl.so.0.9.7.

Can some one clearly explain me why is it my java program by default trying to use libssl.so.0.9.8 when libssl.so.0.9.7 is present.

Thanks in advance,
Joshua
# 2  
Your license library:
/export/home/emsadmin/joshua/libLicense.so

is linked against that version of OpenSSL.

0.9.8 is not part of the Solaris installation, so you will have to install OpenSSL 0.9.8 for example from Freeware for Solaris
# 3  
Thanks a lot buddy.
But can i recompile my native library libLicense.so so that it takes libssl.so 0.9.7 without having to install OpenSSL 0.9.8?
# 4  
If it doesn't need anything that is specifically in 0.9.8 then yes you can.
# 5  
just create a symlink:

cd /usr/local/ssl/lib
ln -s libssl.so.0.9.7 libssl.so.0.9.8

I beleive it should then work Smilie Just take it easy Smilie
# 6  
It might work, but it's not a clean solution.

Suppose there is a need to upgrade from 0.9.7 to 0.9.8 for some other reason. There will then be a link which will prevent the later package from installing correctly.
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #776
Difficulty: Medium
The Fourier transform (FT) decomposes a function of time (a signal) into its constituent frequencies.
True or False?

10 More Discussions You Might Find Interesting

1. What is on Your Mind?

PHP Fatal Errors During SSL Cert Management - PHP Fatal error: xc_fcntl_mutex failed

Today, I noticed some errors in our SSL cert renewal log files, mostly related to domains where the IP address had changed. Concerned about this, rebuilt out SSL cert, which normally goes well without a hiccup. However, for today, for some reason which I cannot explain, there was a PHP error... (0 Replies)
Discussion started by: Neo
0 Replies

2. Solaris

Sendmai l: libssl.so.0.9.7: open failed

Hey for some reason I think I deleted a critical file for sendmail. I was looking the log file on /var/log/cron for cron, and the file isn't there and I found out the reason why is because I'm missing libssl.so.0.9.7. Im running Solaris 11. I checked smtp and got the following: #svcs -xv... (3 Replies)
Discussion started by: picolin
3 Replies

3. Solaris

./curl -V showing fatal: libldap.so.5: open failed: No such file or directory

Hi Guys, I am facing this Error bash-2.03$ ./curl -V ld.so.1: curl: fatal: libldap.so.5: open failed: No such file or directory Killed bash-2.03$ while executing ./curl -V in /opt/sfw/bin directory. I am using Sun Solaris 10. which package upgrage can give me this missing... (9 Replies)
Discussion started by: manalisharmabe
9 Replies

4. Solaris

Solaris 8 zone installation faile in solris 10

dear all i am unable to install Solaris 8 OS in Solaris 10 zone in sun fire V250 and OS Solaris 5.10 Generic_144488-17 following is the installation log and Information about solaris 8 image bash-3.00# flar info "/opt/s8-system.flar" bash-3.00# more... (5 Replies)
Discussion started by: nikhil kasar
5 Replies

5. AIX

UnsatisfiedLinkError with Java1.6 in AIX6.1

Hi Folks, I'm facing the below error when loading my library on AIX6.1 java.lang.UnsatisfiedLinkError: marimba (A file or directory in the path name do es not exist.) at java.lang.ClassLoader.loadLibraryWithPath(ClassLoader.java:1013) at... (7 Replies)
Discussion started by: Bharath_M
7 Replies

6. Shell Programming and Scripting

fatal: cannot open file `TNAME' for reading (No such file or directory)

Hi, I am running this command through a shell script and getting the error mentioned in the subject line: testing.awk -f x.txt TNAME My testing.awk file contains something like ++++++++++++++++++ #!/usr/bin/awk -f BEGIN{ TAB_NAME="INSERT_ONE_" ARGV ; } if ( $1=="JAM_ONE" &&... (1 Reply)
Discussion started by: kunwar
1 Replies

7. Solaris

Error- ld.so.1: expr: fatal: libgmp.so.3: open failed:No such file or directory

Hi Friends I have a compiler(Sun Forte,I believe) running in my Solaris 9 box. since y'day my development team is finding this error when they compile: ld.so.1: expr: fatal: libgmp.so.3: open failed: No such file or directory I ran a search for this file and found it in one of my file... (2 Replies)
Discussion started by: Hari_Ganesh
2 Replies

8. UNIX for Dummies Questions & Answers

Receiving error on Unix server-- java.lang.UnsatisfiedLinkError: registerNatives

Hi all, This is my first shell script, so I'm hoping the problem is that I'm just missing something, and not something bigger. I have a Java application that I wrote in WSAD that reads data from an Excel file and inserts values into a DB2 database. I'm able to run it successfully in WSAD. I... (4 Replies)
Discussion started by: loveToBlade
4 Replies

9. Linux

java unsatisfiedLinkError

I have an ant build file im using to build and run a software package im developing. I'm writing an automatic build script that will each night pull a clean project from CVS, build it, and run some tests on it. I have everything running but the tests. The test requires the running of a seperate... (0 Replies)
Discussion started by: kingfinny
0 Replies

10. News, Links, Events and Announcements

Open Java

"A GPL-ed Java would be Microsoft's biggest nightmare." See the article: http://linuxtoday.com/news_story.php3?ltsn=2004-02-24-023-26-OP-CY-DV (0 Replies)
Discussion started by: photon
0 Replies

Featured Tech Videos