Visit Our UNIX and Linux User Community


Solaris 10 Speed and Duplex Settings: bge


 
Thread Tools Search this Thread
Operating Systems Solaris Solaris 10 Speed and Duplex Settings: bge
# 8  
Old 08-31-2009
i would try this:

remove all interfaces from the config file which are ok in speed and duplex setting (bge0, 2 and 3). make the following entry to the file:

Code:
# interface bge1
name="bge" parent="/pci@0,600000/pci@0/pci@1/pci@0" unit-address="4,1" \
adv_autoneg_cap=0 adv_1000fdx_cap=1 adv_1000hdx_cap=0 \
adv_100fdx_cap=0 adv_100hdx_cap=0 adv_100T4_cap=0 adv_10fdx_cap=0 \
adv_10hdx_cap=0;

after the changes do a:

Code:
# svcadm restart network/physical

or
Code:
# init 6

# 9  
Old 08-31-2009
Once this change is made and the interfaces are restarted the dladm show-dev returns the following:

Code:
bge0            link: up        speed: 1000  Mbps       duplex: full
bge1            link: down      speed: 0     Mbps       duplex: unknown
bge2            link: up        speed: 1000  Mbps       duplex: full
bge3            link: unknown   speed: 0     Mbps       duplex: unknown
nxge0           link: up        speed: 1000  Mbps       duplex: full
nxge1           link: up        speed: 100   Mbps       duplex: full
nxge2           link: up        speed: 1000  Mbps       duplex: full
nxge3           link: unknown   speed: 1000  Mbps       duplex: full

# 10  
Old 08-31-2009
are the old entries still inside the file?

Code:
#########################################################################
#
# The property below represents the list of subsystem vendor/device pairs
# with which driver operation is supported.  This list will be updated and
# extended as new subsystems are validated ...
#
bge-known-subsystems    = 0x108e1647,
                          0x108e1648,
                          0x108e16a7,
                          0x108e16a8,
                          0x17c20010,
                          0x17341013,
                          0x101402a6,
                          0x10f12885,
                          0x17c20020,
                          0x10b71006,
                          0x10280109,
                          0x1028865d,
                          0x0e11005a,
                          0x103c12bc;
#########################################################################
bge-rx-rings            = 1;
bge-tx-rings            = 1;
# interface bge1
name="bge" parent="/pci@0,600000/pci@0/pci@1/pci@0" unit-address="4,1" \
adv_autoneg_cap=0 adv_1000fdx_cap=1 adv_1000hdx_cap=0 \
adv_100fdx_cap=0 adv_100hdx_cap=0 adv_100T4_cap=0 adv_10fdx_cap=0 \
adv_10hdx_cap=0;

if this doesn't work, the "parent" settings are maybe in a wrong format...

edit:
one other idea. delete the "backslash" and try to use one long line...

edit2:
also if the switch is on 100hdx setting without autoneg, your settings won't work and the port goes down... maybe you should have a drink with one of the network guys Smilie.

Last edited by DukeNuke2; 08-31-2009 at 06:10 PM..
# 11  
Old 08-31-2009
No, they have been removed.
# 12  
Old 08-31-2009
Quote:
Originally Posted by brialt1
No, they have been removed.
i updated my last post! <--

Last edited by DukeNuke2; 08-31-2009 at 06:17 PM..
# 13  
Old 08-31-2009
Sorry missed that, I'm pretty sure its option 3 on your list. Unfortunately I don't have access to the switch... I'll see if I can pin down one of the network guys. Thanks for all the help btw Smilie
# 14  
Old 08-31-2009
your welcome and i'm out... have a good night.

Previous Thread | Next Thread
Test Your Knowledge in Computers #383
Difficulty: Medium
Solaris 2.5.1 was registered as UNIX 95 compliant on the PReP PowerPC platform.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Need script help for monitoring duplex settings

So I have a server I am trying to set up a script to send a Wall message notifying of my eth0 nic being set to 100 half duplex instead of 100 full duplex. I know I am trying to read from /etc/sysconfig/network/ifcfg-eth0 to pull the parameters STARTMODE=onboot BOOTPROTO=static... (6 Replies)
Discussion started by: lutador72
6 Replies

2. AIX

Connected and Running with half duplex speed

VIO Server connected to switch port and running with half duplex speed on one of the shared ethernet adapter. We have verified at switch end and everythings looks good. Other ethernet adapter in the VIO server are connected and running in Full duplex speed. Please help me find why this shared... (4 Replies)
Discussion started by: mugunthanvh
4 Replies

3. AIX

How to change Speed Duplex

How to change Speed Duplex ! How to change Speed Duplex by command chdev -P -l ent1 -a media_speed=1000_Full_Duplex How to change Speed Duplex by Smitty . smitty chgenet -> select adapter -> change Media speed etc. -> set "Apply change to DATABASE only" to yes -> Enter -> ... (0 Replies)
Discussion started by: ITHelper
0 Replies

4. Solaris

How to find half duplex or full duplex

Hi, How to find whether the server is running with half duplex or full duplex. I tried with the following command ndd -get /dev/ but am not getting any output,. Is the command correct? Also let me know how to change from half to full duplex. (1 Reply)
Discussion started by: rogerben
1 Replies

5. Infrastructure Monitoring

How to find the duplex speed on Windows

Hi, In UNIX, it's very easy to find the duplex speed. But in Windows, is there a easy way to find the duplex speed? I can't go to over 100 servers to find this out, I was wondering if I run one command to do this? Please advice. (2 Replies)
Discussion started by: samnyc
2 Replies

6. UNIX for Advanced & Expert Users

How to set full duplex for solaris 5.5

I would like to change half duplex to full duplex on solaris 5.5. I tried with below commands but they didnt work on solaris 5.5. #ndd -set /dev/le adv_100fdx_cap 1 (6 Replies)
Discussion started by: csreenivas
6 Replies

7. Solaris

gigabit - fix speed/duplex on the switch ? or autoneg ?

Hi there We have a bit of a debate going here over what the prefered method is for setting 1000/Full on e1000g or nge interfaces is. As you aware the Solaris configration files for nge and e1000g dont allow you to "fix" 1000/Full but instead allow you to set auto-negotiate to ON but only... (1 Reply)
Discussion started by: hcclnoodles
1 Replies

8. HP-UX

command to change duplex settings..

Hi Folks, I want the command to change the duplex settings of a HP-UX server. Thanks in advance. Sagar. (2 Replies)
Discussion started by: sag71155
2 Replies

9. IP Networking

NIC speed 100M/full duplex problem

I have a TOSHIBA AS7000 B150 Sun Box I wanted to run it with 100M/full duplex I had added this to the /etc/system file to make to setting permenant So it would be set correctly on reboot. set eri:eri_adv_100fdx_cap=1 set eri:eri_adv_100hdx_cap=0 set eri:eri_adv_autoneg_cap=0 But when I... (4 Replies)
Discussion started by: AirWalker83
4 Replies

10. Solaris

Duplex Settings

Hi All I've been having a lot of errors logged on the Cisco Catalyst (4000 series) which one of my Solaris servers is patched into. I have a feeling they are duplex related, but I'm a bit stuck as to how to confirm that. How do I: 1. Check the duplex settings on my eri0 card? 2. Set the... (3 Replies)
Discussion started by: saabir
3 Replies

Featured Tech Videos