Visit Our UNIX and Linux User Community


PCI device probe and find


 
Thread Tools Search this Thread
Top Forums Programming PCI device probe and find
# 1  
Old 05-17-2002
Question PCI device probe and find

Smilie
Hi, everybody.

Pleeeeese HLP!!!

I write PCI device driver for bridge controller PCI-VME bus in freeBSD 2.2.
And firs run function probe():

static char* probe(tag, type).

Whuy probe() don't work for my vendorID and deviceID (bridge controller and videoadapter). But probe() work with network adapters.
Example:

#define TUNDRA_UNIVERSE 0x000010e3ul

......


static char *
alx_probe (pcici_t tag, pcidi_t type)
{

switch (type) {
case TUNDRA_UNIVERSE: /* TUNDRA_NIVERSE - is constant device ID*/
return("Tundra Universe||"); /* - probe is successful*/
};
return ((char *)0); /*probe error*/
}

.......

for Russian

Смысл этого корявого английского сообщения (как мог - видит бог я этого не хотел) в том, что мой драйвер моста PCI-VME ( да и для видеокарты тоже) не находит нужное ему устройство в prob по deviceID и vendorID, но самое непонятное такие устройства как сетевые карты или контроллеры (что то связанной с IDE) он определяет довольно резво.
Драйвер пишу под freeBSD2.2 - тока не спрашивайте почему в такой древней - работа...
# 2  
Old 06-01-2002
I am not so much experienced on device drivers but trying to develop one, basically on Streams. I always wish to have expertise people in my friends list for any discussion and deliberations.
Please acknowledge my humbel request to be a close colleague of me. We can discuss a lot via e-mails. Mail Me at prasad@hmastarware.com

Previous Thread | Next Thread
Test Your Knowledge in Computers #65
Difficulty: Easy
In the TCP/IP model, end-to-end connectivity is provided from host-to-host in the transport layer.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Can't find a device under /dev

Hi all, I am trying to see /dev/hwrng but can not find it. There are /dev/random and /dev/urandom but not the hwrng. Works the same config at other os. Any idea what might be happening ? Thanks (2 Replies)
Discussion started by: t35t
2 Replies

2. Red Hat

Find out which eth or device belongs to interface "port 1 PCI 4"

Hi, Iґve given only this info to configure a network interface : "port 1 PCI 4" Iґve been searching for any kind of relationship in the system which allow me to find the etc that must be configured... Please, could anybody help me? rhxx:#/root# lspci |grep -i "PCI BRIDGE" 00:01.0 PCI... (0 Replies)
Discussion started by: pabloli150
0 Replies

3. AIX

unknow pci device as seen by lsslot or lscfg

on a p5 520, running aix 7.1 with the latest TL and SP.. had a 133 MHz Sun PCI 1G or quad 4 x 100 Meg Ethernet card installed.. but it shows unknown type using using lscfg or lsslot Is there addtional drivers to be installed ??? did the same thing on a SYMBIOS Ultra320 diff... (2 Replies)
Discussion started by: ppchu99
2 Replies

4. AIX

AIX -How to find which NIC is on which PCI card

Hi All, How can I find out which is ETH5 on my AIX P5 system. I have about seven different NIC card on this. I did move the cable to each one but still I was not able to see the link light up when I did netstat -v Any idea? Thanks. (2 Replies)
Discussion started by: samnyc
2 Replies

5. AIX

How to find all device on p570 when need do device firmware upgrade?

I need upgrade firmware for the device of p570, when I go to IBM FIX download website, there are a lot of device of p570 listed. How can I know what device I have on my p570? (4 Replies)
Discussion started by: rainbow_bean
4 Replies

6. BSD

PROBE not find the device ID

Hi All, Probe is not returning the Device ID, while device (PCI Express-to-PCI Bridge) is already detected by "lspci". I checked this with printing all the device ID which has been detected. Can anyone give me any suggestion or solution. Thanks (in advance) Appu (2 Replies)
Discussion started by: appu
2 Replies

7. UNIX for Dummies Questions & Answers

Device Probe freezes after detecting Ethernet address while installing FreeeBSD 7.0

I'm trying to install FreeBSD 7.0 from CDs I made a few months ago on a brand new system with parts I just got in from NewEgg. I select the default option from the Boot Loader and it goes into the device probe. Several devices are recognized, but then it freezes at: mskc0: <Marvell Yukon... (2 Replies)
Discussion started by: ideogon
2 Replies

8. SCO

Anyone know how to fix a pci device unknow message

Hi I just buy a new PCI 66 scsi smart array 5300 compaq card, and when I instaled it on an ML350 on the slot pci 66 doesn't works, on bios say unknow pci device, i put it on another ml 330 server and it's the same, finally i tested it on an ML530 server wiїhich has one of that kind of card and it... (0 Replies)
Discussion started by: jactroo
0 Replies

9. UNIX for Advanced & Expert Users

Identifying onboard PCI device

Hi all, I have customized tool that displays PCI device information (something similar to the linux - "lspci") . Now, I need to display information only on "plug-in" cards. Are there any ways to distinguish between "on-board" PCI device and a PCI "plug-in" card. Thanks, Dhilip (2 Replies)
Discussion started by: diliphere
2 Replies

10. Filesystems, Disks and Memory

Mod probe can't find module ppp0

All I am facing a problem, I will explain what happenned: 1. I was on the box... saw a lot of defunct processes. 2. I tried to do an ls on /root (and many other dirs)... got the message "Segmentation fault". 3. Rebooted the box 4. At bootup I noted that I was not getting the screen that... (1 Reply)
Discussion started by: skotapal
1 Replies

Featured Tech Videos