Query: drv_usectohz
OS: sunos
Section: 9f
Links: sunos man pages all man pages
Forums: forum home forum categories
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
drv_usectohz(9F) Kernel Functions for Drivers drv_usectohz(9F)NAMEdrv_usectohz - convert microseconds to clock ticksSYNOPSIS#include <sys/types.h> #include <sys/ddi.h> clock_t drv_usectohz(clock_t microsecs);INTERFACE LEVELArchitecture independent level 1 (DDI/DKI).PARAMETERSmicrosecs The number of microseconds to convert.DESCRIPTIONdrv_usectohz() converts a length of time expressed in microseconds to a number of system clock ticks. The time arguments to timeout(9F) and delay(9F) are expressed in clock ticks. drv_usectohz() is a portable interface for drivers to make calls to timeout(9F) and delay(9F) and remain binary compatible should the driver object file be used on a system with a different clock speed (a different number of ticks in a second).RETURN VALUESThe value returned is the number of system clock ticks equivalent to the microsecs argument. No error value is returned. If the clock tick equivalent to microsecs is too large to be represented as a clock_t, then the maximum clock_t value will be returned.CONTEXTdrv_usectohz() can be called from user or interrupt context.SEE ALSOdelay(9F), drv_hztousec(9F), timeout(9F) Writing Device Drivers SunOS 5.10 12 Nov 1992 drv_usectohz(9F)