Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

drv_usectohz(9f) [sunos man page]

drv_usectohz(9F)					   Kernel Functions for Drivers 					  drv_usectohz(9F)

NAME
drv_usectohz - convert microseconds to clock ticks SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> clock_t drv_usectohz(clock_t microsecs); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
microsecs The number of microseconds to convert. DESCRIPTION
drv_usectohz() converts a length of time expressed in microseconds to a number of system clock ticks. The time arguments to timeout(9F) and delay(9F) are expressed in clock ticks. drv_usectohz() is a portable interface for drivers to make calls to timeout(9F) and delay(9F) and remain binary compatible should the driver object file be used on a system with a different clock speed (a different number of ticks in a second). RETURN VALUES
The value returned is the number of system clock ticks equivalent to the microsecs argument. No error value is returned. If the clock tick equivalent to microsecs is too large to be represented as a clock_t, then the maximum clock_t value will be returned. CONTEXT
drv_usectohz() can be called from user or interrupt context. SEE ALSO
delay(9F), drv_hztousec(9F), timeout(9F) Writing Device Drivers SunOS 5.10 12 Nov 1992 drv_usectohz(9F)

Check Out this Related Man Page

drv_usectohz(9F)					   Kernel Functions for Drivers 					  drv_usectohz(9F)

NAME
drv_usectohz - convert microseconds to clock ticks SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> clock_t drv_usectohz(clock_t microsecs); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
microsecs The number of microseconds to convert. DESCRIPTION
drv_usectohz() converts a length of time expressed in microseconds to a number of system clock ticks. The time arguments to timeout(9F) and delay(9F) are expressed in clock ticks. drv_usectohz() is a portable interface for drivers to make calls to timeout(9F) and delay(9F) and remain binary compatible should the driver object file be used on a system with a different clock speed (a different number of ticks in a second). RETURN VALUES
The value returned is the number of system clock ticks equivalent to the microsecs argument. No error value is returned. If the clock tick equivalent to microsecs is too large to be represented as a clock_t, then the maximum clock_t value will be returned. CONTEXT
drv_usectohz() can be called from user or interrupt context. SEE ALSO
delay(9F), drv_hztousec(9F), timeout(9F) Writing Device Drivers SunOS 5.10 12 Nov 1992 drv_usectohz(9F)
Man Page

4 More Discussions You Might Find Interesting

1. Programming

clock() function

Hey all, i need a program to get the CPU ticks at certain points of my program. So, i thought about using the clock function, but i'm having a hard time figuring out how it really works. I wrote this simple program to try to understand it but it made me feel more confused: #include <stdio.h>... (5 Replies)
Discussion started by: kastrup_carioca
5 Replies

2. Linux

kernel error!

Hi, Nov 13 12:47:53 FIREWALL003 kernel: warning: many lost ticks. Nov 13 12:47:53 FIREWALL003 kernel: Your time source seems to be instable or some driver is hogging interupts Nov 13 12:47:53 FIREWALL003 kernel: rip __do_softirq+0x4d/0xd0 I was able to login at 1pm but I can't do anything. ... (5 Replies)
Discussion started by: itik
5 Replies

3. Programming

Accessing TSC Register

I'm accessing the TSC register, and using usleep() function to calculate my clock frequency. Basically, I check the current clock, delay for 1 second, and then check the clock again to discover how many clock ticks occur in a second. The only problem is - my result turns out to be a... (1 Reply)
Discussion started by: snowbarr
1 Replies

4. Shell Programming and Scripting

Back ticks and $()

In one of my previous threads, someone suggested not to use backticks. When I googled, I came to know that back ticks are deprecated instead $() should be used. But I face issue while using $(). Note: I used echo of the sql just to debug. The following is the code #!/bin/ksh #set -x... (5 Replies)
Discussion started by: bobbygsk
5 Replies