Query: scsi_hba_init
OS: opensolaris
Section: 9f
Links: opensolaris man pages all man pages
Forums: unix linux community forum categories
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
scsi_hba_init(9F) Kernel Functions for Drivers scsi_hba_init(9F)NAMEscsi_hba_init, scsi_hba_fini - SCSI Host Bus Adapter system initialization and completion routinesSYNOPSIS#include <sys/scsi/scsi.h> int scsi_hba_init(struct modlinkage *modlp); void scsi_hba_fini(struct modlinkage *modlp);INTERFACE LEVELSolaris architecture specific (Solaris DDI).PARAMETERSmodlp Pointer to the Host Bus Adapters module linkage structure.DESCRIPTIONscsi_hba_init() scsi_hba_init() is the system-provided initialization routine for SCSI HBA drivers. The scsi_hba_init() function registers the HBA in the system and allows the driver to accept configuration requests on behalf of SCSI target drivers. The scsi_hba_init() routine must be called in the HBA's _init(9E) routine before mod_install(9F) is called. If mod_install(9F) fails, the HBA's _init(9E) should call scsi_hba_fini() before returning failure. scsi_hba_fini() scsi_hba_fini() is the system provided completion routine for SCSI HBA drivers. scsi_hba_fini() removes all of the system references for the HBA that were created in scsi_hba_init(). The scsi_hba_fini() routine should be called in the HBA's _fini(9E) routine if mod_remove(9F) is successful.RETURN VALUESscsi_hba_init() returns 0 if successful, and a non-zero value otherwise. If scsi_hba_init() fails, the HBA's _init() entry point should return the value returned by scsi_hba_init().CONTEXTscsi_hba_init() and scsi_hba_fini() should be called from _init(9E) or _fini(9E), respectively.SEE ALSO_fini(9E), _init(9E), mod_install(9F), mod_remove(9F), scsi_pktalloc(9F), scsi_pktfree(9F), scsi_hba_tran(9S) Writing Device DriversNOTESThe HBA is responsible for ensuring that no DDI request routines are called on behalf of its SCSI target drivers once scsi_hba_fini() is called. SunOS 5.11 1 Nov 1993 scsi_hba_init(9F)
Related Man Pages |
---|
scsi_hba_init(9f) - sunos |
scsi_hba_init(9f) - opensolaris |
mod_info(9f) - centos |
mod_remove(9f) - php |
mod_install(9f) - minix |
Similar Topics in the Unix Linux Community |
---|
FreeBSD nVidia Beta Drivers released! |
How to get HBA details in Solaris 9 ? |
backward string cut |
Solaris 10 + mpxio Path |
lun masking at qlogic HBA level |