opensolaris man page for ldi_ev_remove_callbacks

Query: ldi_ev_remove_callbacks

OS: opensolaris

Section: 9f

Links: opensolaris man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ldi_ev_remove_callbacks(9F)				   Kernel Functions for Drivers 			       ldi_ev_remove_callbacks(9F)

NAME
ldi_ev_remove_callbacks - remove all callbacks for a given callback ID
SYNOPSIS
#include <sys/sunldi.h> void ldi_ev_remove_callbacks(ldi_ev_callback_id_t id);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
ldi_ev_callback_id_t id An opaque data structure returned on successful calls to ldi_ev_register_callbacks(9F).
DESCRIPTION
The ldi_ev_remove_callback() function unregisters any callbacks that were registered via ldi_ev_register_callbacks(9F). Once this function returns, the callback ID is no longer valid. The finalize and notify callbacks exist independently of the LDI handle and are not automatically removed when the LDI handle is closed. The layered driver removes these callbacks via ldi_ev_remove_callbacks()() when the callbacks are no longer needed. The LDI framework may panic the system if the entity registering the callback (a dev_t, dip or module) no longer exists on the system and the callbacks have not been unregistered.
RETURN VALUES
None.
CONTEXT
This function can be called from user and kernel contexts only.
SEE ALSO
ldi_ev_get_cookie(9F), ldi_ev_register_callbacks(9F) SunOS 5.11 21 Aug 2007 ldi_ev_remove_callbacks(9F)
Related Man Pages
usb_register_hotplug_cbs(9f) - sunos
usb_unregister_hotplug_cbs(9f) - sunos
ldi_ev_finalize(9f) - opensolaris
ldi_ev_notify(9f) - opensolaris
usb_unregister_hotplug_cbs(9f) - opensolaris
Similar Topics in the Unix Linux Community
Trying to block signal
How to learn UNIX
PHP Man Pages Now Available (Over 10,000)
Grep the 'not running' jobs and will send the update in mail with its name(job)
Identify problem with while getopts