opensolaris man page for bcmp

Query: bcmp

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

bcmp(9F)						   Kernel Functions for Drivers 						  bcmp(9F)

NAME
bcmp - compare two byte arrays
SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> int bcmp(const void *s1, const void *s2, size_t len);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
s1 Pointer to the first character string. s2 Pointer to the second character string. len Number of bytes to be compared.
DESCRIPTION
The bcmp() function compares two byte arrays of length len.
RETURN VALUES
The bcmp() function returns 0 if the arrays are identical, or 1 if they are not.
CONTEXT
The bcmp() function can be called from user, interrupt, or kernel context.
SEE ALSO
strcmp(9F) Writing Device Drivers
NOTES
Unlike strcmp(9F), bcmp() does not terminate when it encounters a null byte. SunOS 5.11 16 Jan 2006 bcmp(9F)
Related Man Pages
bcopy(3c) - opensolaris
bcmp(3) - linux
bcmp(3) - debian
bcmp(3) - opendarwin
bcmp(3) - plan9
Similar Topics in the Unix Linux Community
Need help in building gcc on solaris.
Unix gurus : how to grep this pattern?
Not able to find the perfect code...Geting confused in between
sed adding a new line not working