Query: mstohz
OS: netbsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
MSTOHZ(9) BSD Kernel Developer's Manual MSTOHZ(9)NAMEmstohz, hztoms -- convert between milliseconds and system clock ticksSYNOPSIS#include <sys/param.h> int mstohz(int ms); int hztoms(int hz);DESCRIPTIONThe mstohz() macro can be used to convert time in milliseconds to system clock ticks, as used by the callout(9) facility, in an integer-over- flow safe way. Conversely, hztoms() converts system clock ticks to milliseconds. These macros are defined in the <sys/param.h> header. Individual ports can have a processor-specific, more efficient version implemented in their <machine/param.h> header as a define.RETURN VALUESThe return value is either the number of clock ticks or milliseconds for the specified value.SEE ALSOparam(3), callout(9), tvtohz(9)BUGSNeither mstohz() nor hztoms() make use of expensive 64-bit integer arithmetic. The result from mstohz() will be rounded down to one second if the parameter is larger than 131072 milliseconds.BSDOctober 20, 2011 BSD
Related Man Pages |
---|
kpause(9) - netbsd |
drv_usectohz(9f) - sunos |
drv_usectohz(9f) - debian |
drv_usectohz(9f) - suse |
drv_usectohz(9f) - v7 |
Similar Topics in the Unix Linux Community |
---|
Memory Leaks |
Vm versus physical linux server |
RFC - Korn shell prompt |
Adding a List of Times |
Grep command to show the number of results |