TVTOHZ(9) BSD Kernel Developer's Manual TVTOHZ(9)NAME
tvtohz -- convert time interval to tick count
SYNOPSIS
#include <sys/time.h>
int
tvtohz(struct timeval *tv);
DESCRIPTION
The tvtohz() function accepts a single argument tv which specifies the time interval over which to calculate the number of system ticks that
would elapse.
RETURN VALUES
Returns the integral number of system ticks expected to elapse in the given interval, including the current tick.
SEE ALSO timeval(3), callout(9), microtime(9), microuptime(9), mstohz(9)HISTORY
The tvtohz function first appeared in FreeBSD 3.0 and was ported to NetBSD 4.0 as a part of timecounter(9) framework.
AUTHORS
This manual page was written by Kelly Yancey <kbyanc@posi.net>.
BSD October 20, 2011 BSD
Check Out this Related Man Page
MICROTIME(9) BSD Kernel Developer's Manual MICROTIME(9)NAME
bintime, getbintime, microtime, getmicrotime, nanotime, getnanotime -- get the current time
SYNOPSIS
#include <sys/time.h>
void
bintime(struct bintime *bt);
void
getbintime(struct bintime *bt);
void
microtime(struct timeval *tv);
void
getmicrotime(struct timeval *tv);
void
nanotime(struct timespec *ts);
void
getnanotime(struct timespec *tsp);
DESCRIPTION
The bintime() and getbintime() functions store the system time as a struct bintime at the addresses specified by bt. The microtime() and
getmicrotime() functions perform the same utility, but record the time as a struct timeval instead. Similarly the nanotime() and
getnanotime() functions store the time as a struct timespec.
The bintime(), microtime(), and nanotime() functions always query the timecounter to return the current time as precisely as possible.
Whereas getbintime(), getmicrotime(), and getnanotime() functions are abstractions which return a less precise, but faster to obtain, time.
The intent of the getbintime(), getmicrotime(), and getnanotime() functions is to enforce the user's preference for timer accuracy versus
execution time.
SEE ALSO binuptime(9), getbinuptime(9), getmicrouptime(9), getnanouptime(9), microuptime(9), nanouptime(9), tvtohz(9)HISTORY
The bintime functions first appeared in FreeBSD 5.0. The microtime and nanotime functions first appeared in FreeBSD 3.0 but have existed in
other incarnations since 4.4BSD.
AUTHORS
This manual page was written by Kelly Yancey <kbyanc@posi.net>.
BSD September 16, 2004 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)