freebsd man page for vfs_sync

Query: vfs_sync

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VFS_SYNC(9)						   BSD Kernel Developer's Manual					       VFS_SYNC(9)

NAME
VFS_SYNC -- flush unwritten data
SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_SYNC(struct mount *mp, int waitfor);
DESCRIPTION
The VFS_SYNC() macro writes out all unwritten data in the file system mounted as mp. The arguments it expects are: mp The file system. waitfor Whether the function should wait for I/O to complete. Possible values are: MNT_WAIT synchronously wait for I/O to complete MNT_NOWAIT start all I/O, but do not wait for it MNT_LAZY push data not written by file system syncer The VFS_SYNC() macro calls the vfs_sync method of the file system, which normally calls VOP_FSYNC(9) for all the vnodes in the file system.
SEE ALSO
fsync(2), sync(2), VFS(9), vnode(9), VOP_FSYNC(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
May 23, 2009 BSD
Related Man Pages
vfs_unmount(9) - netbsd
vfs(9) - freebsd
vop_fsync(9) - opensolaris
vop_fsync(9) - centos
vop_fsync(9) - redhat
Similar Topics in the Unix Linux Community
Unix File Permissions
The Whole Story on #! /usr/bin/ksh
A simple UNIXtime component in Vue.js
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?