Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

untimeout(9f) [sunos man page]

untimeout(9F)						   Kernel Functions for Drivers 					     untimeout(9F)

NAME
untimeout - cancel previous timeout function call SYNOPSIS
#include <sys/types.h> #include <sys/conf.h> clock_t untimeout(timeout_id_t id); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
id Opaque timeout ID from a previous timeout(9F) call. DESCRIPTION
untimeout() cancels a pending timeout(9F) request. untimeout() will not return until the pending callback is cancelled or has run. Because of this, locks acquired by the callback routine should not be held across the call to untimeout() or a deadlock may result. Since no mutex should be held across the call to untimeout(), there is a race condition between the occurrence of an expected event and the execution of the timeout handler. In particular, it should be noted that no problems will result from calling untimeout() for a timeout which is either running on another CPU, or has already completed. Drivers should be structured with the understanding that the arrival of both an interrupt and a timeout for that interrupt can occasionally occur, in either order. RETURN VALUES
untimeout() returns -1 if the id is not found. Otherwise, it returns an integer value greater than or equal to 0. CONTEXT
untimeout() can be called from user or interrupt context. EXAMPLES
In the following example, the device driver has issued an IO request and is waiting for the device to respond. If the device does not respond within 5 seconds, the device driver will print out an error message to the console. static void xxtimeout_handler(void *arg) { struct xxstate *xsp = (struct xxstate *)arg; mutex_enter(&xsp->lock); cv_signal(&xsp->cv); xsp->flags |= TIMED_OUT; mutex_exit(&xsp->lock); xsp->timeout_id = 0; } static uint_t xxintr(caddr_t arg) { struct xxstate *xsp = (struct xxstate *)arg; . . . mutex_enter(&xsp->lock); /* Service interrupt */ cv_signal(&xsp->cv); mutex_exit(&xsp->lock); if (xsp->timeout_id != 0) { (void) untimeout(xsp->timeout_id); xsp->timeout_id = 0; } return(DDI_INTR_CLAIMED); } static void xxcheckcond(struct xxstate *xsp) { . . . xsp->timeout_id = timeout(xxtimeout_handler, xsp, (5 * drv_usectohz(1000000))); mutex_enter(&xsp->lock); while (/* Waiting for interrupt or timeout*/) cv_wait(&xsp->cv, &xsp->lock); if (xsp->flags & TIMED_OUT) cmn_err(CE_WARN, "Device not responding"); . . . mutex_exit(&xsp->lock); . . . } SEE ALSO
open(9E), cv_signal(9F), cv_wait_sig(9F), delay(9F), timeout(9F) Writing Device Drivers SunOS 5.10 18 Feb 1998 untimeout(9F)

Check Out this Related Man Page

ddi_dev_is_needed(9F)					   Kernel Functions for Drivers 				     ddi_dev_is_needed(9F)

NAME
ddi_dev_is_needed - inform the system that a device's component is required SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dev_is_needed(dev_info_t *dip, int component, int level); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the device's dev_info structure. component Component of the driver which is needed. level Power level at which the component is needed. DESCRIPTION
The ddi_dev_is_needed() function is obsolete and will be removed in a future release. It is recommended that device drivers use pm_raise_power(9F) and pm_lower_power(9F). The ddi_dev_is_needed() function informs the system that a device component is needed at the specified power level. The level argument must be non-zero. This function sets a component to the required level and sets all devices which depend on this to their normal power levels. The state of the device should be examined before each physical access. The ddi_dev_is_needed() function should be called to set a compo- nent to the required power level if the operation to be performed requires the component to be at a power level other than its current level. The ddi_dev_is_needed() function might cause re-entry of the driver. Deadlock may result if driver locks are held across the call to ddi_dev_is_needed(). RETURN VALUES
The ddi_dev_is_needed() function returns: DDI_SUCCESS Power successfully set to the requested level. DDI_FAILURE An error occurred. EXAMPLES
Example 1: disk driver code A hypothetical disk driver might include this code: static int xxdisk_spun_down(struct xxstate *xsp) { return (xsp->power_level[DISK_COMPONENT] < POWER_SPUN_UP); } static int xxdisk_strategy(struct buf *bp) { ... mutex_enter(&xxstate_lock); /* * Since we have to drop the mutex, we have to do this in a loop * in case we get preempted and the device gets taken away from * us again */ while (device_spun_down(sp)) { mutex_exit(&xxstate_lock); if (ddi_dev_is_needed(xsp->mydip, XXDISK_COMPONENT, XXPOWER_SPUN_UP) != DDI_SUCCESS) { bioerror(bp,EIO); biodone(bp); return(0); } mutex_enter(&xxstate_lock); } xsp->device_busy++; mutex_exit(&xxstate_lock); ... } CONTEXT
This function can be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +--------------------------+--------------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +--------------------------+--------------------------------+ |Interface stability | Obsolete | +--------------------------+--------------------------------+ SEE ALSO
pm(7D), pm-components(9P), attach(9E), detach(9E), power(9E), pm_busy_component(9F), pm_idle_component(9F) Writing Device Drivers SunOS 5.10 7 Dec 2003 ddi_dev_is_needed(9F)
Man Page