Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_event2text(9f) [sunos man page]

csx_Event2Text(9F)					   Kernel Functions for Drivers 					csx_Event2Text(9F)

NAME
csx_Event2Text - convert events to text strings SYNOPSIS
#include <sys/pccard.h> int32_t csx_Event2Text(event2text_t *ev); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ev Pointer to an event2text_t structure. DESCRIPTION
This function is a Solaris-specific extension that provides a method for clients to convert Card Services events to text strings. STRUCTURE MEMBERS
The structure members of event2text_t are: event_t event; /*the event code*/ char text[CS_EVENT_MAX_BUFSIZE] /*the event code*/ The fields are defined as follows: event The text for the event code in the event field is returned in the text field. text The text string describing the name of the event. RETURN VALUES
CS_SUCCESS Successful operation. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. EXAMPLES
Example 1: : Using csx_Event2Text() xx_event(event_t event, int priority, event_callback_args_t *eca) { event2text_t event2text; event2text.event = event; csx_Event2Text(&event2text); cmn_err(CE_CONT, "event %s (0x%x)", event2text.text, (int)event); } SEE ALSO
csx_event_handler(9E), csx_Error2Text(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_Event2Text(9F)

Check Out this Related Man Page

csx_Event2Text(9F)					   Kernel Functions for Drivers 					csx_Event2Text(9F)

NAME
csx_Event2Text - convert events to text strings SYNOPSIS
#include <sys/pccard.h> int32_t csx_Event2Text(event2text_t *ev); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ev Pointer to an event2text_t structure. DESCRIPTION
This function is a Solaris-specific extension that provides a method for clients to convert Card Services events to text strings. STRUCTURE MEMBERS
The structure members of event2text_t are: event_t event; /*the event code*/ char text[CS_EVENT_MAX_BUFSIZE] /*the event code*/ The fields are defined as follows: event The text for the event code in the event field is returned in the text field. text The text string describing the name of the event. RETURN VALUES
CS_SUCCESS Successful operation. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. EXAMPLES
Example 1 : Using csx_Event2Text() xx_event(event_t event, int priority, event_callback_args_t *eca) { event2text_t event2text; event2text.event = event; csx_Event2Text(&event2text); cmn_err(CE_CONT, "event %s (0x%x)", event2text.text, (int)event); } SEE ALSO
csx_event_handler(9E), csx_Error2Text(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 19 Jul 1996 csx_Event2Text(9F)
Man Page

7 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

How to remove FIRST Line of huge text file on Solaris

i need help..!!!! i have one big text file estimate data file size 50 - 100GB with 70 Mega Rows. on OS SUN Solaris version 8 How i can remove first line of the text file. Please suggest me for solutions. Thank you very much in advance:) (5 Replies)
Discussion started by: madoatz
5 Replies

2. Programming

To convert UHF-8 to ASCII using C++

Hi, I have two strings aaa, bbb which contains text in UTF-8 format. I am using Solaris OS. zsh shell, emacs editor. In the shell the text are represented like "fff'''(((#ip##iii^q##1..... Example: aaa="fff'''(((#ip##iii^q##1".. I need to compare the two strings, I feel that text in this... (3 Replies)
Discussion started by: SamRoj
3 Replies

3. Programming

trying to convert binary data to text using C++

i hav tried to convert binary 2D data into text using binreader and writing into text file using streamwriter. i use ReadSingle() function to convert from binary to ascii, although it works good in 1D data but not in more dimensions. the kind of values i get are -1.265369923E+038 and like ... (2 Replies)
Discussion started by: geet
2 Replies

4. Shell Programming and Scripting

Removing text between two static strings

Hi everyone, I need to replace the text between two strings (html tags) and I'm having trouble figuring out how to do so. I can display the text with sed but I'm not having any luck deleting the text between the two strings. My file looks like this: <oths>test</oths><div class="text">1928... (2 Replies)
Discussion started by: cg2
2 Replies

5. Shell Programming and Scripting

Extracting text between two strings

Hi, I've looked at a few existing posts on this, but they don't seem to work for my inputs. I have a text file where I want to extract all the text between two strings, every time that occurs. Eg my input file is Anna said that she would fetch the bucket. Anna and Ben moved the bucket.... (9 Replies)
Discussion started by: JamesForeman
9 Replies

6. UNIX for Dummies Questions & Answers

How to convert a text file into tab delimited format?

I have a text file that made using text editor in Ubuntu. However the text file is not being recognized as space or tab delimited, the formatting seems to be messed up. How can I convert the text file into tab delimited format? (3 Replies)
Discussion started by: evelibertine
3 Replies

7. Shell Programming and Scripting

Sed command question on Solaris

Hi, I'm trying to find the first field in a text file with the below sed command but it doesn't seem to be correct for running on Solaris.. It has no problem running on AIX. Anyone got a suggestion what the problem is? sed 's/^\(\+\) /OK/' The eventual goal is to separate the columns in a... (5 Replies)
Discussion started by: Jazmania
5 Replies