Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_error2text(9f) [sunos man page]

csx_Error2Text(9F)					   Kernel Functions for Drivers 					csx_Error2Text(9F)

NAME
csx_Error2Text - convert error return codes to text strings SYNOPSIS
#include <sys/pccard.h> int32_t csx_Error2Text(error2text_t *er); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
er Pointer to an error2text_t structure. DESCRIPTION
This function is a Solaris-specific extension that provides a method for clients to convert Card Services error return codes to text strings. STRUCTURE MEMBERS
The structure members of error2text_t are: uint32_t item; /*the error code*/ char test[CS_ERROR_MAX_BUFSIZE}; /*the error code*/ A pointer to the text for the Card Services error return code in the item field is returned in the text field if the error return code is found. The client is not responsible for allocating a buffer to hold the text. If the Card Services error return code specified in the item field is not found, the text field will be set to a string of the form: "{unknown Card Services return code}" RETURN VALUES
CS_SUCCESS Successful operation. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. EXAMPLES
Example 1: : Using the csxError2Text function if ((ret = csx_RegisterClient(&client_handle, & client_reg)) != CS_SUCCESS) { error2text_t error2text; error2text.item = ret; csx_Error2Text(&error2text); cmn_err(CE_CONT, "RegisterClient failed %s (0x%x)", error2text.text, ret); } SEE ALSO
csx_Event2Text(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_Error2Text(9F)

Check Out this Related Man Page

csx_ValidateCIS(9F)					   Kernel Functions for Drivers 				       csx_ValidateCIS(9F)

NAME
csx_ValidateCIS - validate the Card Information Structure (CIS) SYNOPSIS
#include <sys/pccard.h> int32_t csx_ValidateCIS(client_handle_t ch, cisinfo_t *ci); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). ci Pointer to a cisinfo_t structure. DESCRIPTION
This function validates the Card Information Structure (CIS) on the PC Card in the specified socket. STRUCTURE MEMBERS
The structure members of cisinfo_t are: uint32_t Socket; /* socket number to validate CIS on */ uint32_t Chains; /* number of tuple chains in CIS */ uint32_t Tuples; /* total number of tuples in CIS */ The fields are defined as follows: Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. Chains This field returns the number of valid tuple chains located in the CIS. If 0 is returned, the CIS is not valid. Tuples This field is a Solaris-specific extension and it returns the total number of tuples on all the chains in the PC Card's CIS. RETURN VALUES
CS_SUCCESS Successful operation. CS_NO_CIS No CIS on PC Card or CIS is invalid. CS_NO_CARD No PC Card in socket. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_ParseTuple(9F), csx_RegisterClient(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_ValidateCIS(9F)
Man Page

4 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Unix Services (Solaris 9)

(2 Replies)
Discussion started by: BCarlson
2 Replies

2. UNIX for Dummies Questions & Answers

How to remove FIRST Line of huge text file on Solaris

i need help..!!!! i have one big text file estimate data file size 50 - 100GB with 70 Mega Rows. on OS SUN Solaris version 8 How i can remove first line of the text file. Please suggest me for solutions. Thank you very much in advance:) (5 Replies)
Discussion started by: madoatz
5 Replies

3. Programming

To convert UHF-8 to ASCII using C++

Hi, I have two strings aaa, bbb which contains text in UTF-8 format. I am using Solaris OS. zsh shell, emacs editor. In the shell the text are represented like "fff'''(((#ip##iii^q##1..... Example: aaa="fff'''(((#ip##iii^q##1".. I need to compare the two strings, I feel that text in this... (3 Replies)
Discussion started by: SamRoj
3 Replies

4. Shell Programming and Scripting

Help with Comparing 2 strings from text

Hey guys how do I compare 2 strings from the text file, and check for duplication? For example, I add an item call Laptop, it will record to the textfile call file. If it detects duplicate it will say the record record exist? file.txt contains Laptop:Sony:1000 Phone:Apple:30 A head... (4 Replies)
Discussion started by: aLHaNz
4 Replies