Query: strlog
OS: sunos
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
strlog(9F) Kernel Functions for Drivers strlog(9F)NAMEstrlog - submit messages to the log driverSYNOPSIS#include <sys/stream.h> #include <sys/strlog.h> #include <sys/log.h> int strlog(short mid, short sid, char level, unsigned short flags, char *fmt, ...););INTERFACE LEVELArchitecture independent level 1 (DDI/DKI).PARAMETERSmid Identification number of the module or driver submitting the message (in the case of a module, its mi_idnum value from mod- ule_info(9S)). sid Identification number for a particular minor device. level Tracing level for selective screening of low priority messages. Larger values imply less important information. flags Valid flag values are: SL_ERROR Message is for error logger. SL_TRACE Message is for trace. SL_NOTIFY Mail copy of message to system administrator. SL_CONSOLE Log message to console. SL_FATAL Error is fatal. SL_WARN Error is a warning. SL_NOTE Error is a notice. fmt printf(3C) style format string. %e, %g, and %G formats are not allowed but %s is supported.DESCRIPTIONstrlog() expands the printf(3C) style format string passed to it, that is, the conversion specifiers are replaced by the actual argument values in the format string. The 32-bit representations of the arguments (up to NLORGARGS) follow the string starting at the next 32-bit boundary following the string. Note that the 64-bit argument will be truncated to 32-bits here but will be fully represented in the string. The messages can be retrieved with the getmsg(2) system call. The flags argument specifies the type of the message and where it is to be sent. strace(1M) receives messages from the log driver and sends them to the standard output. strerr(1M) receives error messages from the log driver and appends them to a file called /var/adm/streams/error.mm-dd, where mm-dd identifies the date of the error message.RETURN VALUESstrlog() returns 0 if it fails to submit the message to the log(7D) driver and 1 otherwise.CONTEXTstrlog() can be called from user or interrupt context.FILES/var/adm/streams/error.mm-dd Error messages dated mm-dd appended by strerr(1M) from the log driverSEE ALSOstrace(1M), strerr(1M), getmsg(2), log(7D), module_info(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 strlog(9F)
Related Man Pages |
---|
strerr(1m) - hpux |
log(7) - osf1 |
strlog(7) - osf1 |
strace(8) - osf1 |
strerr(1m) - sunos |
Similar Topics in the Unix Linux Community |
---|
System Error messages |
Error messages in /var/adm |
CPU Panic. |
[kern.warning] messages in /var/adm/messages |
Why there are /var/adm/messages.0,messages.1,messages.2,messages.3 |