Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

qsize(9f) [sunos man page]

qsize(9F)						   Kernel Functions for Drivers 						 qsize(9F)

NAME
qsize - find the number of messages on a queue SYNOPSIS
#include <sys/stream.h> int qsize(queue_t *q); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Queue to be evaluated. DESCRIPTION
qsize() evaluates the queue q and returns the number of messages it contains. RETURN VALUES
If there are no message on the queue, qsize() returns 0. Otherwise, it returns the integer representing the number of messages on the queue. CONTEXT
qsize() can be called from user or interrupt context. SEE ALSO
Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 qsize(9F)

Check Out this Related Man Page

canput(9F)						   Kernel Functions for Drivers 						canput(9F)

NAME
canput - test for room in a message queue SYNOPSIS
#include <sys/stream.h> int canput(queue_t *q); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the message queue. DESCRIPTION
canput() searches through the stream (starting at q) until it finds a queue containing a service routine where the message can be enqueued, or until it reaches the end of the stream. If found, the queue containing the service routine is tested to see if there is room for a mes- sage in the queue. canputnext(q) and bcanputnext(q, pri) should always be used in preference to canput(q->q_next) and bcanput(q->q_next, pri) respectively. RETURN VALUES
1 If the message queue is not full. 0 If the queue is full. CONTEXT
canput() can be called from user or interrupt context. SEE ALSO
bcanput(9F), bcanputnext(9F), canputnext(9F), putbq(9F), putnext(9F) Writing Device Drivers STREAMS Programming Guide WARNINGS
Drivers are responsible for both testing a queue with canput() and refraining from placing a message on the queue if canput() fails. SunOS 5.10 11 Apr 1991 canput(9F)
Man Page

9 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

ioctl() system call on Linux-i386

Greetings, Please help me with the following : Where can I find what means exactly and how to use each of the second argument of the ioctl() system call in Linux/386 : FIOxxx (file IOCTL requests), SIOxxx (socket IOCTL requests), TCxxx TIOxxx (terminal IOCTL requests) ? ... (1 Reply)
Discussion started by: aigoia
1 Replies

2. Programming

why printf() function don't go work?

I use FreeBSD,and use signal,like follows: signal(SIGHUP,sig_hup); signal(SIGIO,sig_io); when I run call following code,it can run,but I find a puzzled question,it should print some information,such as printf("execute main()") will print execute main(),but in fact,printf fuction print... (2 Replies)
Discussion started by: konvalo
2 Replies

3. AIX

Port hang issue in AIX Version 5.3

On AIX platform we are having Weblogic 8.1 as the middleware for an application. The application is deployed in Weblogic on AIX platform and the server is having 2 dedicated listening ports for any incoming requests. Output for netstat -an command for the port 30001 is as follows:- tcp4... (7 Replies)
Discussion started by: subharai
7 Replies

4. Filesystems, Disks and Memory

Issue available disk space while using xdd

Good morning, I seem to be running into an issue with some drives I have attached to my solaris server. The drives are attached correctly, the partitions are arranged with fdisk, the ext3 filesystem is setup using mkfs, and finally the drive is mounted. When I use xdd to perform read/write... (3 Replies)
Discussion started by: mrpogo07
3 Replies

5. AIX

Should I be worried about my AIX Cluster?

I have a 2-node Power 7 - 16cpu - 32gb RAM - AIX 6L cluster. The production node has 10 physical cpus (40 cores) and 24gb of RAM. The cluster has been live for 6 weeks and I'm seeing some things on the production node that I think could be of concern but wanted to get some opinions. The... (6 Replies)
Discussion started by: troym72
6 Replies

6. Programming

Thread parameter in ANSI C makes a segmentation fault

The creation of thread. void Client_Constructor ( const char* IPAddr ) { pthread_t tid; pthread_attr_t rx; /* Create separate memory for client argument */ struct ThreadArgs *threadArgs; if ( ( threadArgs = ( struct ThreadArgs* ) malloc( sizeof( struct ThreadArgs )... (14 Replies)
Discussion started by: sehang
14 Replies

7. Shell Programming and Scripting

Parsing text file

Hi Friends, I am back for the second round today - :D My input text file is this way Home friends friendship meter Tools Mirrors Downloads My Data About Us Help My own results BLAT Search Results ACTIONS QUERY SCORE START END QSIZE IDENTITY CHRO STRAND ... (7 Replies)
Discussion started by: jacobs.smith
7 Replies

8. AIX

AIX 6.1 reach the threshold of stream(no -a|grep strthresh)

last night i want to do oracle full backup with expdp when i switch to oracle it hangs,it looks like: su - oracle there is nothing feedback and hang ,but su - root work fine. then i use truss su - oracle found it stuck at "ENOSR" ,then i changed the kernel parameter of strthresh from 85 to 90... (7 Replies)
Discussion started by: machinen
7 Replies

9. AIX

Wait process holding CPU

Hi all, Have this performance Issue, srvbd1]root]/]>ps vg | head -1 ; ps vg | grep -w wait PID TTY STAT TIME PGIN SIZE RSS LIM TSIZ TRS %CPU %MEM COMMAND 8196 - A 4448:23 0 384 384 xx 0 0 12.8 0.0 wait 53274 - A 4179:28 0 384 ... (9 Replies)
Discussion started by: gopeezere
9 Replies