opensolaris man page for csx_error2text

Query: csx_error2text

OS: opensolaris

Section: 9f

Links: opensolaris man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

csx_Error2Text(9F)					   Kernel Functions for Drivers 					csx_Error2Text(9F)

NAME
csx_Error2Text - convert error return codes to text strings
SYNOPSIS
#include <sys/pccard.h> int32_t csx_Error2Text(error2text_t *er);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)
PARAMETERS
er Pointer to an error2text_t structure.
DESCRIPTION
This function is a Solaris-specific extension that provides a method for clients to convert Card Services error return codes to text strings.
STRUCTURE MEMBERS
The structure members of error2text_t are: uint32_t item; /*the error code*/ char test[CS_ERROR_MAX_BUFSIZE}; /*the error code*/ A pointer to the text for the Card Services error return code in the item field is returned in the text field if the error return code is found. The client is not responsible for allocating a buffer to hold the text. If the Card Services error return code specified in the item field is not found, the text field will be set to a string of the form: "{unknown Card Services return code}"
RETURN VALUES
CS_SUCCESS Successful operation. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.
CONTEXT
This function may be called from user or kernel context.
EXAMPLES
Example 1 : Using the csxError2Text function if ((ret = csx_RegisterClient(&client_handle, & client_reg)) != CS_SUCCESS) { error2text_t error2text; error2text.item = ret; csx_Error2Text(&error2text); cmn_err(CE_CONT, "RegisterClient failed %s (0x%x)", error2text.text, ret); }
SEE ALSO
csx_Event2Text(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 19 Jul 1996 csx_Error2Text(9F)
Related Man Pages
csx_deregisterclient(9f) - sunos
csx_maplogsocket(9f) - sunos
csx_event2text(9f) - opensolaris
csx_mapmempage(9f) - opensolaris
csx_resetfunction(9f) - opensolaris
Similar Topics in the Unix Linux Community
Unix Services (Solaris 9)
How to remove FIRST Line of huge text file on Solaris
To convert UHF-8 to ASCII using C++
Help with Comparing 2 strings from text