Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

bp_mapin(9f) [sunos man page]

bp_mapin(9F)						   Kernel Functions for Drivers 					      bp_mapin(9F)

NAME
bp_mapin - allocate virtual address space SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> void bp_mapin(struct buf *bp); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
bp Pointer to the buffer header structure. DESCRIPTION
bp_mapin() is used to map virtual address space to a page list maintained by the buffer header during a paged- I/O request. bp_mapin() allocates system virtual address space, maps that space to the page list, and returns the starting address of the space in the bp->b_un.b_addr field of the buf(9S) structure. Virtual address space is then deallocated using the bp_mapout(9F) function. If a null page list is encountered, bp_mapin() returns without allocating space and no mapping is performed. CONTEXT
bp_mapin() can be called from user and kernel contexts. SEE ALSO
bp_mapout(9F), buf(9S) Writing Device Drivers SunOS 5.10 13 Sep 1992 bp_mapin(9F)

Check Out this Related Man Page

bp_mapout(9F)						   Kernel Functions for Drivers 					     bp_mapout(9F)

NAME
bp_mapout - deallocate virtual address space SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> void bp_mapout(struct buf *bp); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
bp Pointer to the buffer header structure. DESCRIPTION
bp_mapout() deallocates system virtual address space allocated by a previous call to bp_mapin(9F).bp_mapout() should only be called on buffers which have been allocated and are owned by the device driver. It must not be called on buffers passed to the driver through the strategy(9E) entry point (for example a filesystem). Because bp_mapin(9F) does not keep a reference count, bp_mapout() will wipe out any kernel mapping that a layer above the device driver might rely on. CONTEXT
bp_mapout() can be called from user context only. SEE ALSO
strategy(9E), bp_mapin(9F), buf(9S) Writing Device Drivers SunOS 5.10 15 Nov 1996 bp_mapout(9F)
Man Page

5 More Discussions You Might Find Interesting

1. AIX

Removing page space

I having problem removing a page space.... 1. When I list the page spaces available in the system, I am getting the following messages 0516-310 : Unable to find attribute state in the Device Configuration Database. Execute synclvodm to attempt to correct the database.... (4 Replies)
Discussion started by: srnkumar
4 Replies

2. UNIX for Dummies Questions & Answers

How to assign virtual address?.

Hello,I am new to unix,i want to know how to assign virtual ip address to a system that is in my personal network? (1 Reply)
Discussion started by: veeru_jarugula
1 Replies

3. Shell Programming and Scripting

Storing string with space (urgent)

hi i have a file content like my_file: 1US8738297897918000 000 000 i used while IFS= read line do echo "$line" | grep '^\ then last=`echo "$line" | cut -c 3-20` echo "$last" fi done < $my_file but it is writing blank spaces into the o/p fie (1 Reply)
Discussion started by: Satyak
1 Replies

4. Programming

Find Virtual address space size for process

Hi, I am looking to work on unix systems which include (hp-ux, ibm aix, solaris and linux). I want to get the total virtual address space of a process, the used virtual memory i am able to get without any problem. I have tried using getrlimit and getrlimit64, but that gives only ... (4 Replies)
Discussion started by: uiqbal
4 Replies

5. Shell Programming and Scripting

Replacing space with T only in the 1st line of the file

Hi Masters , I have a file whose header is like HDRCZECM8CZCM000000881 SVR00120100401160828+020020100401160828+0200CZK There is a space between 1 and S ,my req is to chng the space to T I tried echo `head -1 CDCZECM8CZCM000000881` | sed 's/ /T/' it works ,but how can I modify in... (5 Replies)
Discussion started by: Pratik4891
5 Replies