PROTOCOLS(5) BSD File Formats Manual PROTOCOLS(5)NAME
protocols -- protocol name data base
The protocols file contains information regarding the known protocols used in the DARPA Internet. For each protocol a single line should be
present with the following information:
official protocol name
Items are separated by any number of blanks and/or tab characters. A ``#'' indicates the beginning of a comment; characters up to the end of
the line are not interpreted by routines which search the file.
Protocol names may contain any printable character other than a field delimiter, newline, or comment character.
INTERACTION WITH DIRECTORY SERVICES
Processes generally find protocol records using one of the getprotoent(3) family of functions. On Mac OS X, these functions interact with
the DirectoryService(8) daemon, which reads the /etc/protocols file as well as searching other directory information services to determine
protocol name and number information.
SEE ALSO getprotoent(3), DirectoryService(8)HISTORY
The protocols file format appeared in 4.2BSD.
4.2 Berkeley Distribution June 5, 1993 4.2 Berkeley Distribution
Check Out this Related Man Page
protocols(4) Kernel Interfaces Manual protocols(4)NAME
protocols - Defines the Internet protocols used on the local host
The /etc/protocols file contains information about the known protocols used in the DARPA (Defense Advanced Research Projects Agency) Inter-
net. Each protocol is represented by a single line in the protocols file. Each entry is of the form: Name Number Aliases
The fields contain the following information: Official Internet protocol name. Protocol number. Unofficial names used for the protocol.
Items on a line are separated by one or more spaces or tab characters. Comments begin with the # (number sign), and routines that search
the protocols file do not interpret characters from the beginning of a comment to the end of the line. A protocol name can contain any
printable character except a field delimiter, newline character, or comment character.
The lines in the file appear as follows: # # Internet (IP) protocols # ip 0 IP # internet protocol, pseudo protocol number
icmp 1 ICMP # internet control message protocol igmp 2 IGMP # internet group management protocol ggp 3 GGP
# gateway-gateway protocol tcp 6 TCP # transmission control protocol egp 8 EGP # exterior gateway protocol pup
12 PUP # PARC universal packet protocol udp 17 UDP # user datagram protocol hmp 20 HMP # host monitoring
protocol rdp 27 RDP # "reliable datagram" protocol
Functions: endprotoent(3), getprotobyname(3), getprotobynumber(3), getprotoent(3), setprotoent(3) delim off
I've been trying to set up the phantom protocol just to try it out. I compiled it fine, but when I ran it I got an error that the configuration file wouldn't load. I found that file didn't exist, so I created it with a blank file, but got this:
Loading configuration file... (4 Replies)
planning to secure AIX sever by disabling insecure protocols/cipher suites; got the below requirements from secuirty team.
1.configure the server to disable support for DES and IDEA cipher suites
2.disable insecure TLS/SSL protocol support
Configure the server to... (4 Replies)
a quick google search making clear that this isn't really new, and if we look at our bsd Forum we see that its the only operation systems forum with the last comment dated to June last year, whereas all the others have more recent comments.
One comment dated to 2014 is exactly what I... (10 Replies)