Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

usb_unregister_hotplug_cbs(9f) [opensolaris man page]

usb_register_hotplug_cbs(9F)				   Kernel Functions for Drivers 			      usb_register_hotplug_cbs(9F)

NAME
usb_register_hotplug_cbs, usb_unregister_hotplug_cbs - Register/unregister for notification of device hotplug events SYNOPSIS
#include <sys/usb/usba.h> int usb_register_hotplug_cbs(dev_info_t *dip, int (*disconnection_event_handler)(dev_info_t *dip, int (*reconnection_event_handler)(dev_info_t *dip); void usb_unregister_hotplug_cbs(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
For usb_register_hotplug_cbs() dip Pointer to the device's dev_info structure. disconnection_event_handler Called when device is disconnected. This handler takes a dev_info_t as an argument (representing the device being disconnected) and always returns USB_SUCCESS. reconnection_event_handler Called when device is reconnected. This handler takes a dev_info_t as an argument (representing the device being reconnected) and always returns USB_SUCCESS. For usb_unregister_hotplug_cbs(): dip Pointer to the device's dev_info structure. DESCRIPTION
The usb_register_hotplug_cbs() function registers callbacks to be executed when the USB device represented by dip is hotplugged or removed. The usb_unregister_hotplug_cbs() function unregisters or disengages callbacks from executing when the USB device represented by dip is hot- plugged or removed. RETURN VALUES
For usb_register_hotplug_cbs(): USB_SUCCESS Callbacks were successfully registered. USB_FAILURE One or more arguments were NULL. Callbacks could not be successfully registered. For usb_unregister_hotplug_cbs(): None CONTEXT
The usb_register_hotplug_cbs() function may be called only from attach(9E). The usb_unregister_hotplug_cbs() function may be called only from detach(9E). Registered callback handlers requiring the use of any DDI (section 9F) function (except ddi_taskq_* functions), should launch a separate thread using ddi_taskq_* routines for processing their event, to avoid deadlocks. The new thread can then safely call any DDI function it needs to handle the event. The registered callback handlers execute in kernel context. EXAMPLES
int remove_device(dev_info_t *) { ... ... return (USB_SUCCESS); } int accommodate_device(dev_info_t *) { ... ... return (USB_SUCCESS); } if (usb_register_hotplug_cbs( dip, remove_device, accommodate_device) == USB_FAILURE) { cmn_err (CE_WARN, "%s%d: Could not register hotplug handlers.", ddi_driver_name(dip), ddi_get_instance(dip)); } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), attach(9E), detach(9E), usb_get_status(9F) SunOS 5.11 17 Aug 2004 usb_register_hotplug_cbs(9F)

Check Out this Related Man Page

usb_create_pm_components(9F)				   Kernel Functions for Drivers 			      usb_create_pm_components(9F)

NAME
usb_create_pm_components - Create power management components for USB devices SYNOPSIS
#include <sys/usb/usba.h> int usb_create_pm_components(dev_info_t *dip, uint_t *pwrstates); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the device's dev_info structure. pwrstates Address into which a mask which lists power states capable by device is returned. This is a bitmask containing zero or more of the following values: USB_DEV_PWRMASK_D0 Corresponds to USB_DEV_OS_PWR_3 or full power. USB_DEV_PWRMASK_D1 Corresponds to USB_DEV_OS_PWR_2. USB_DEV_PWRMASK_D2 Corresponds to USB_DEV_OS_PWR_1. USB_DEV_PWRMASK_D3 Corresponds to USB_DEV_OS_PWR_0 or no power. DESCRIPTION
The usb_create_pm_components() function creates pm component properties that assume the standard USB D0-D3 powerlevels (USB_DEV_PWR_D0 - USB_DEV_PWR_D3). See the device's relevant USB descriptor to determine the device's power management capabilities and account for bus-pow- ered devices. The usb_create_pm_components() function also updates the pm-components property in the device's dev_info structure. Note that these USB power levels are inverse of OS power levels. For example, USB_DEV_OS_PWR_0 and USB_DEV_PWR_D3 are equivalent levels corresponding to powered-down. RETURN VALUES
USB_SUCCESS Power management facilities in device are recognized by system. USB_FAILURE An error occurred. CONTEXT
May be called from user or kernel context. EXAMPLES
uint_t *pwrstates; /* Hook into device's power management. Enable remote wakeup. */ if (usb_create_pm_components(dip, pwrstates) == USB_SUCCESS) { usb_handle_remote_wakeup(dip,USB_REMOTE_WAKEUP_ENABLE); } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), usb_clr_feature(9F), usb_register_hotplug_cbs(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_handle_remote_wakeup(9F), pm_idle_component(9F), pm_busy_component(9F), pm_raise_power(9F), pm_lower_power(9F), usb_cfg_descr(9S) SunOS 5.11 5 Jan 2004 usb_create_pm_components(9F)
Man Page