Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

usb_unregister_hotplug_cbs(9f) [opensolaris man page]

usb_register_hotplug_cbs(9F)				   Kernel Functions for Drivers 			      usb_register_hotplug_cbs(9F)

NAME
usb_register_hotplug_cbs, usb_unregister_hotplug_cbs - Register/unregister for notification of device hotplug events SYNOPSIS
#include <sys/usb/usba.h> int usb_register_hotplug_cbs(dev_info_t *dip, int (*disconnection_event_handler)(dev_info_t *dip, int (*reconnection_event_handler)(dev_info_t *dip); void usb_unregister_hotplug_cbs(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
For usb_register_hotplug_cbs() dip Pointer to the device's dev_info structure. disconnection_event_handler Called when device is disconnected. This handler takes a dev_info_t as an argument (representing the device being disconnected) and always returns USB_SUCCESS. reconnection_event_handler Called when device is reconnected. This handler takes a dev_info_t as an argument (representing the device being reconnected) and always returns USB_SUCCESS. For usb_unregister_hotplug_cbs(): dip Pointer to the device's dev_info structure. DESCRIPTION
The usb_register_hotplug_cbs() function registers callbacks to be executed when the USB device represented by dip is hotplugged or removed. The usb_unregister_hotplug_cbs() function unregisters or disengages callbacks from executing when the USB device represented by dip is hot- plugged or removed. RETURN VALUES
For usb_register_hotplug_cbs(): USB_SUCCESS Callbacks were successfully registered. USB_FAILURE One or more arguments were NULL. Callbacks could not be successfully registered. For usb_unregister_hotplug_cbs(): None CONTEXT
The usb_register_hotplug_cbs() function may be called only from attach(9E). The usb_unregister_hotplug_cbs() function may be called only from detach(9E). Registered callback handlers requiring the use of any DDI (section 9F) function (except ddi_taskq_* functions), should launch a separate thread using ddi_taskq_* routines for processing their event, to avoid deadlocks. The new thread can then safely call any DDI function it needs to handle the event. The registered callback handlers execute in kernel context. EXAMPLES
int remove_device(dev_info_t *) { ... ... return (USB_SUCCESS); } int accommodate_device(dev_info_t *) { ... ... return (USB_SUCCESS); } if (usb_register_hotplug_cbs( dip, remove_device, accommodate_device) == USB_FAILURE) { cmn_err (CE_WARN, "%s%d: Could not register hotplug handlers.", ddi_driver_name(dip), ddi_get_instance(dip)); } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), attach(9E), detach(9E), usb_get_status(9F) SunOS 5.11 17 Aug 2004 usb_register_hotplug_cbs(9F)

Check Out this Related Man Page

usb_handle_remote_wakeup(9F)				   Kernel Functions for Drivers 			      usb_handle_remote_wakeup(9F)

NAME
usb_handle_remote_wakeup - Enable or disable remote wakeup on USB devices SYNOPSIS
#include <sys/usb/usba.h> int usb_handle_remote_wakeup(dev_info_t *dip, int cmd); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the device's dev_info structure. cmd Command. Either USB_REMOTE_WAKEUP_ENABLE or USB_REMOTE_WAKEUP_DISABLE. DESCRIPTION
The usb_handle_remote_wakeup() function enables or disables remote wakeup on a USB device. This call can block. RETURN VALUES
USB_SUCCESS Remote wakeup is successfully enabled or disabled. USB_FAILURE Remote wakeup is not supported by the device. An internal error occurred. CONTEXT
May be called from user or kernel context. EXAMPLES
uint_t *pwrstates; /* Hook into device's power management. Enable remote wakeup. */ if (usb_create_pm_components(dip, pwrstates) == USB_SUCCESS) { usb_handle_remote_wakeup(dip, USB_REMOTE_WAKEUP_ENABLE); } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Evolving | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), pm_busy_component(9F), pm_idle_component(9F), pm_lower_power(9F), pm_raise_power(9F), usb_clr_feature(9F), usb_cre- ate_pm_components(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_register_hotplug_cbs(9F), usb_cfg_descr(9S) SunOS 5.10 5 Feb 2004 usb_handle_remote_wakeup(9F)
Man Page