Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_fm_ereport_post(9f) [opensolaris man page]

ddi_fm_ereport_post(9F) 				   Kernel Functions for Drivers 				   ddi_fm_ereport_post(9F)

NAME
ddi_fm_ereport_post - post an FMA Protocol Error Report Event SYNOPSIS
#include <sys/ddifm.h> void ddi_fm_ereport_post(dev_info_t *dip, char *ereport_class, uint64_t ena, int *sflag, ... /* name-value pair args */); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the dev_info structure ereport_class FMA Event Protocol error class ena Error Numeric Association sflag Determines whether caller can sleep for memory or other event resources. DESCRIPTION
The ddi_fm_ereport_post() function causes an encoded fault management error report name-value pair list to be queued for delivery to the Fault Manager daemon, fmd(1M). The sflag parameter indicates whether or not the caller is willing to wait for system memory and event chan- nel resources to become available. The following ereport_class strings are available for use by any leaf device driver: device.inval_state A leaf driver discovers that the device is in an invalid or inconsistent state. For example, the driver might detect that receive or send ring descriptor indices are corrupted. It might also find an invalid value in a regis- ter or a driver-to-device protocol violation. device.no_response A leaf driver times out waiting for a response from the device. For example, timeouts can occur when no confirma- tion is seen after resetting, enabling, or disabling part of the device. device.badint_limit A leaf device sends too many consecutive interrupts with no work to do. device.intern_corr A leaf device reports to the driver that it has itself detected an internal correctable error. device.intern_uncorr A leaf device reports to the driver that it has itself detected an internal uncorrectable error. device.stall A leaf driver determines that data transmission has stalled indefinitely. The ena indicates the Format 1 Error Numeric Association for this error report. It might have already been initialized by another error- detecting software module. For example, if ddi_fm_ereport_post() is called from an error handler callback function, the fme_ena field from the passed-in ddi_fm_error argument should be used. Otherwise it should be set to 0 and will be initialized by ddi_fm_ereport_post(). The name-value pair args variable argument list contains one or more (names, type, value pointer) nvpair tuples for non-array data_type_t types or one or more (name, type, number of elements, value pointer) tuples for data_type_t array types. There is one mandatory tuple to describe the ereport version. This should contain the following values: o name - FM_VERSION o type - DATA_TYPE_UINT8 o value - FM_EREPORT_VERS0 Additional nvpair tuples can describe error conditions for logging purposes, but are not interpreted by the I/O framework or fault manager. The end of the argument list is specified by NULL. CONTEXT
The ddi_fm_ereport_post() function can be called from user, kernel, or high-level interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
fmd(1M), attributes(5), ddi_fm_service_impact(9F) SunOS 5.11 14 May 2007 ddi_fm_ereport_post(9F)

Check Out this Related Man Page

ddi_fm_service_impact(9F)				   Kernel Functions for Drivers 				 ddi_fm_service_impact(9F)

NAME
ddi_fm_service_impact - report the impact of an error SYNOPSIS
#include <sys/ddifm.h> void ddi_fm_service_impact(dev_info_t *dip, int *impact); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the dev_info structure impact Impact of error DESCRIPTION
The following service impact values are accepted by ddi_fm_service_impact(): DDI_SERVICE_LOST The service provided by the device is unavailable due to an error. The operational state of the device will tran- sition to DEVI_DEVICE_DOWN. DDI_SERVICE_DEGRADED The driver is unable to provide normal service, but it can provide a partial or degraded level of service. The driver might have to make repeated attempts to perform an operation before it succeeds, or it may be running at less than its configured speed. A driver may use this value to indicate that an alternative device should be used if available, but that it can continue operation if no alternative exists. The operational state of the device will transition to DEVI_DEVICE_DEGRADED. DDI_SERVICE_RESTORED The service provided by the device has been restored. The operational state of the device will transition to its pre-error condition state and DEVI_DEVICE_DOWN or DEVI_DEVICE_DEGRADED is removed. DDI_SERVICE_UNAFFECTED The service provided by the device was unaffected by the error. CONTEXT
The ddi_fm_service_impact() function can be called from user, kernel, or high-level interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
fmd(1M), attributes(5), ddi_fm_ereport_post(9F), pci_ereport_post(9F) SunOS 5.11 14 May 2007 ddi_fm_service_impact(9F)
Man Page