Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_set_driver_private(9f) [opensolaris man page]

ddi_get_driver_private(9F)				   Kernel Functions for Drivers 				ddi_get_driver_private(9F)

NAME
ddi_get_driver_private, ddi_set_driver_private - get or set the address of the device's private data area SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> void ddi_set_driver_private(dev_info_t *dip, void *data); void *ddi_get_driver_private(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
ddi_get_driver_private() dip Pointer to device information structure to get from. ddi_set_driver_private() dip Pointer to device information structure to set. data Data area address to set. DESCRIPTION
The ddi_get_driver_private() function returns the address of the device's private data area from the device information structure pointed to by dip. The ddi_set_driver_private() function sets the address of the device's private data area in the device information structure pointed to by dip with the value of data. RETURN VALUES
The ddi_get_driver_private() function returns the contents of devi_driver_data. If ddi_set_driver_private() has not been previously called with dip, an unpredictable value is returned. CONTEXT
These functions can be called from user , interrupt, or kernel context. SEE ALSO
Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_get_driver_private(9F)

Check Out this Related Man Page

ddi_get_driver_private(9F)				   Kernel Functions for Drivers 				ddi_get_driver_private(9F)

NAME
ddi_get_driver_private, ddi_set_driver_private - get or set the address of the device's private data area SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> void ddi_set_driver_private(dev_info_t *dip, caddr_t data); caddr_t ddi_get_driver_private(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
ddi_get_driver_private() dip Pointer to device information structure to get from. ddi_set_driver_private() dip Pointer to device information structure to set. data Data area address to set. DESCRIPTION
ddi_get_driver_private() returns the address of the device's private data area from the device information structure pointed to by dip. ddi_set_driver_private() sets the address of the device's private data area in the device information structure pointed to by dip with the value of data. RETURN VALUES
ddi_get_driver_private() returns the contents of devi_driver_data. If ddi_set_driver_private() has not been previously called with dip, an unpredictable value is returned. CONTEXT
These functions can be called from user or interrupt context. SEE ALSO
Writing Device Drivers SunOS 5.10 6 Feb 1995 ddi_get_driver_private(9F)
Man Page