Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_get_driver_private(9f) [sunos man page]

ddi_get_driver_private(9F)				   Kernel Functions for Drivers 				ddi_get_driver_private(9F)

NAME
ddi_get_driver_private, ddi_set_driver_private - get or set the address of the device's private data area SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> void ddi_set_driver_private(dev_info_t *dip, caddr_t data); caddr_t ddi_get_driver_private(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
ddi_get_driver_private() dip Pointer to device information structure to get from. ddi_set_driver_private() dip Pointer to device information structure to set. data Data area address to set. DESCRIPTION
ddi_get_driver_private() returns the address of the device's private data area from the device information structure pointed to by dip. ddi_set_driver_private() sets the address of the device's private data area in the device information structure pointed to by dip with the value of data. RETURN VALUES
ddi_get_driver_private() returns the contents of devi_driver_data. If ddi_set_driver_private() has not been previously called with dip, an unpredictable value is returned. CONTEXT
These functions can be called from user or interrupt context. SEE ALSO
Writing Device Drivers SunOS 5.10 6 Feb 1995 ddi_get_driver_private(9F)

Check Out this Related Man Page

ddi_dev_is_sid(9F)					   Kernel Functions for Drivers 					ddi_dev_is_sid(9F)

NAME
ddi_dev_is_sid - tell whether a device is self-identifying SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dev_is_sid(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
dip A pointer to the device's dev_info structure. DESCRIPTION
ddi_dev_is_sid() tells the caller whether the device described by dip is self-identifying, that is, a device that can unequivocally tell the system that it exists. This is useful for drivers that support both a self-identifying as well as a non-self-identifying variants of a device (and therefore must be probed). RETURN VALUES
DDI_SUCCESS Device is self-identifying. DDI_FAILURE Device is not self-identifying. CONTEXT
ddi_dev_is_sid() can be called from user or interrupt context. EXAMPLES
1 ... 2 int 3 bz_probe(dev_info_t *dip) 4 { 5 ... 6 if (ddi_dev_is_sid(dip) == DDI_SUCCESS) { 7 /* 8 * This is the self-identifying version (OpenBoot). 9 * No need to probe for it because we know it is there. 10 * The existence of dip && ddi_dev_is_sid() proves this. 11 */ 12 return (DDI_PROBE_DONTCARE); 13 } 14 /* 15 * Not a self-identifying variant of the device. Now we have to 16 * do some work to see whether it is really attached to the 17 * system. 18 */ 19 ... SEE ALSO
probe(9E) Writing Device Drivers SunOS 5.10 24 Oct 1991 ddi_dev_is_sid(9F)
Man Page