opensolaris man page for bp_mapin

Query: bp_mapin

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

bp_mapin(9F)						   Kernel Functions for Drivers 					      bp_mapin(9F)

NAME
bp_mapin - allocate virtual address space
SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> void bp_mapin(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to the buffer header structure.
DESCRIPTION
bp_mapin() is used to map virtual address space to a page list maintained by the buffer header during a paged- I/O request. bp_mapin() allocates system virtual address space, maps that space to the page list, and returns the starting address of the space in the bp->b_un.b_addr field of the buf(9S) structure. Virtual address space is then deallocated using the bp_mapout(9F) function. If a null page list is encountered, bp_mapin() returns without allocating space and no mapping is performed.
CONTEXT
bp_mapin() can be called from user and kernel contexts.
SEE ALSO
bp_mapout(9F), buf(9S) Writing Device Drivers SunOS 5.11 13 Sep 1992 bp_mapin(9F)
Related Man Pages
bioclone(9f) - opensolaris
bp_mapout(9f) - sunos
bp_copyout(9f) - opensolaris
getrbuf(9f) - redhat
getrbuf(9f) - php
Similar Topics in the Unix Linux Community
Removing page space
How to assign virtual address?.
Virtual IP address in HACMP
Replacing space with T only in the 1st line of the file
PC RAM and process address space