identify(9E) Driver Entry Points identify(9E)NAME
identify - determine if a driver is associated with a device
Solaris DDI specific (Solaris DDI). This entry point is no longer supported. nulldev(9F) must be specified in the dev_ops(9S) structure.
SEE ALSO nulldev(9F), dev_ops(9S)ATTRIBUTES
See attributes(5) for a description of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Stability Level |Obsolete |
For Solaris 10 and later versions, drivers must remove the identify(9e) implementation to recompile. Otherwise, the compiler generates
errors about DDI_IDENTIFIED and DDI_NOT_IDENTIFIED.
SunOS 5.11 11 Apr 2003 identify(9E)
Check Out this Related Man Page
probe(9E) Driver Entry Points probe(9E)NAME
probe - determine if a non-self-identifying device is present
static intprefixprobe(dev_info_t *dip);
Solaris DDI specific (Solaris DDI). This entry point is required for non-self-identifying devices. You must write it for such devices. For
self-identifying devices, nulldev(9F) should be specified in the dev_ops(9S) structure if a probe routine is not necessary.
dip Pointer to the device's dev_info structure.
probe() determines whether the device corresponding to dip actually exists and is a valid device for this driver. probe() is called after
identify(9E) and before attach(9E) for a given dip. For example, the probe() routine can map the device registers using ddi_map_regs(9F)
then attempt to access the hardware using ddi_peek(9F) or ddi_poke(9F) and determine if the device exists. Then the device registers
should be unmapped using ddi_unmap_regs(9F).
To probe a device that was left powered off after the last detach(), it might be necessary to power it up. If so, the driver must power up
the device by accessing device registers directly. pm_raise_power(9F) will be not be available until attach(9E). The framework ensures
that the ancestors of the node being probed and all relevant platform-specific power management hardware is at full power at the time that
probe() is called.
probe() should only probe the device. It should not change any software state and should not create any software state. Device initializa-
tion should be done in attach(9E).
For a self-identifying device, this entry point is not necessary. However, if a device exists in both self-identifying and non-self-iden-
tifying forms, a probe() routine can be provided to simplify the driver. ddi_dev_is_sid(9F) can then be used to determine whether probe()
needs to do any work. See ddi_dev_is_sid(9F) for an example.
"small and bold">DDI_PROIf_theCprobe was successful.
DDI_PROBE_FAILURE If the probe failed.
DDI_PROBE_DONTCARE If the probe was unsuccessful, yet attach(9E) should still be called.
DDI_PROBE_PARTIAL If the instance is not present now, but may be present in the future.
SEE ALSO attach(9E), identify(9E), ddi_dev_is_sid(9F), ddi_map_regs(9F), ddi_peek(9F), ddi_poke(9F), nulldev(9F), dev_ops(9S)
Writing Device Drivers
SunOS 5.10 18 Nov 1992 probe(9E)
OS: Solaris 2.6
File with no name created Mar of 2000 - ls (with or without options) shows the file but no name associated with it.
-rw-r--r-- 1 root other 9721 Apr 16 2003 printcap
-rw-r--r-- 1 root other 267 Apr 16 2003
-rw-r--r-- 1 root other 258 Apr 16... (3 Replies)
i need help..!!!!
i have one big text file estimate data file size 50 - 100GB with 70 Mega Rows.
on OS SUN Solaris version 8
How i can remove first line of the text file.
Please suggest me for solutions.
Thank you very much in advance:) (5 Replies)
I'm not sure whether this thread is in the right subforum, if it isn't please excuse me.
So, here's my question - right now I'm trying to port a Solaris device driver for a custom piece of hardware to Linux (2.6.15), and I'm having some troubles finding the proper corresponding... (3 Replies)
I have two scripts ( /tmp/k1.sh and /tmp/k2.sh ).
k1.sh calls the k2.sh .
For security reasons, I must be sure that the k2.sh is being called by the k1.sh .
Is it possible for the k2.sh identify that it's been called by the k1.sh?
I mean, identify the complete path of the k1.sh (... (6 Replies)
Platform: Sun Solaris ver 9.
Get alert notification from Oracle and the device stated: Disk utilization for ssd29 reached 98%. How can we map this ssd device with something like c1t2d0s0?
Pls help. Thank you. (10 Replies)
I have the following output and would like to only identify strings with "vw" at the end.
Here is the file contents:
SELECT n.contract_num, n.descr, s.prj_level2_cf_val, r.descr, r.project_id,
p.offering_id, o.n_cust_contract, u.name1, ' ', ' ', SUM (0),
TO_CHAR (t.start_dt, 'YYYY-MM-DD'),... (6 Replies)
I have a little problem. I need to identify the server type from some ufsdumps.
How can i do that?
I grepped with:
grep Sun messages*
but with this command, if there server was never rebooted, i cannot recognize the server type.
any other idea?
thx in advance
Ivan (5 Replies)
Could anyone help me on a command to identify distinct values from a particular column ?my input file has header. So i need a command in which we pass Column1 as parameter.
For eg my input is like
Column1 Column2 Column3
... (4 Replies)
we have a string with yyyymmdd format .
how to know which date it is ?
please suggest commands which work on below
os : SunOS 5.10
shell: bash shell
Srinath. (10 Replies)
I am working on VM host and collecting data to identify the type of storage attached to the server which will be migrated to VNX.
it has one ldom created on it
luxadm probe output ---
No Network Array enclosures found in /dev/es
Found Fibre Channel device(s):
Node... (7 Replies)