ipmievd(8) System Manager's Manual ipmievd(8)
ipmievd - IPMI event daemon for sending events to syslog
ipmievd [-chvV] -I lan -H hostname [ -p <port>] [-U <username>] [ -f <password_file>] [-S <sdrcache>] sel [<option>]
ipmievd [-chvV] -I lanplus -H hostname [-p <port>] [-U <username>] [-f <password_file>] [-S <sdrcache>] sel [<option>]
ipmievd [-chvV] -I bmc [-S <sdrcache>] sel [<option>]
ipmievd is a daemon that listens for events from the Baseboard Management Controller (BMC) which are being sent to the System Event Log
(SEL), and logs those messages to syslog. The daemon actively polls the contents of the SEL for new events. When an event is received, it
is logged to syslog using the LOG_LOCAL4 facility. On Solaris, it has been made to use LOG_DAEMON instead, so that no changes to /etc/sys-
log.conf are necessary.
ipmievd is based on the ipmitool utility and it shares the same Intelligent Platform Management Interface (IPMI) support and session setup
options. The ipmitool man page provides more information on supported IPMI interfaces.
-c Present output in comma separated variable (CSV) format.
Specify a file containing the remote server password. If this option is absent, or if password_file is empty, the password will
default to NULL.
If the -f option is not present, ipmitool will prompt the user for a password. If no password is entered at the prompt, the remote
server password will default to NULL.
For IPMI v1.5, the maximum password length is 16 characters. Passwords longer than 16 characters will be truncated.
For IPMI v2.0, the maximum password length is 20 characters. Passwords longer than 20 characters will be truncated. The longer
password length is supported by the lanplus interface.
-h Get basic usage help from the command line.
Remote server address, which can be an IP address or hostname. This option is required for the LAN interface connection.
Selects IPMI interface to use. Possible interfaces are:
bmc IPMI v2.0 BMC interface [default]
lan IPMI v1.5 LAN Interface
lanplus IPMI v2.0 RMCP
Remote server UDP port to connect to (default is 623).
Use local file for remote Sensor Data Repository (SDR) cache. Using a local SDR cache can drastically increase performance for com-
mands that require knowledge of the entire SDR to perform their function.
Remote server username; default is NULL user.
-v Increase verbose output level. This option can be specified multiple times to increase the level of debug output. If given three
times, you will get hexdumps of all incoming and outgoing packets.
-V Display version information.
help This can be used to get command-line help. It can also be placed at the end of commands to get option usage help.
> ipmievd bmc help
sel Poll SEL for notification of events
sel This command starts ipmievd with the SEL Polling event watching mechanism. This will poll the SEL periodically to determine if new
events have been logged. This command should work with all BMCs and is capable of using the LAN interface as well to monitor a
remote system and log its events to a local syslog.
daemon Launch process as a daemon and reparent to init process. All messages will be sent to syslog. This is the default action.
Do not become a daemon; instead, log all messages to stderr.
Save process ID to this file when in daemon mode. Defaults to /var/run/ipmievd.pid.
Time between checks for SEL polling method. Default is 10 seconds.
Upon successful completion, ipmievd returns 0. On failure, 1 is returned.
Local non-daemon process checking remote SEL every 30 seconds:
> ipmievd -I lan -H 184.108.40.206 -f passfile sel nodaemon timeout=30
Waiting for Events...
32-bit ELF kernel module for the bmc driver.
64-bit ELF kernel module for the bmc driver.
Character device node used to communicate with the bmc driver.
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Architecture | i386, amd64 |
|Availability | SUNWipmi |
|Interface Stability | Volatile |
attributes(5), ipmitool(1M), smf(5), svcadm(1M), svccfg(1M), svcs(1)
Intelligent Platform Management Interface Specification
The ipmievd daemon is managed by the service management facility, smf(5), under the service identifier: svc:/network/ipmievd:default.
Administrative actions on this service, such as enabling or disabling, can be performed using svcadm(1M). Use svccfg(1M) to make configura-
tion changes and svcs(1) to view configuration information and service status.
Source for ipmievd is available on http://opensolaris.org.
29 November 2006 ipmievd(8)