|Linux & Unix Commands - Search Man Pages
hal(5) Standards, Environments, and Macros hal(5)
hal - overview of hardware abstraction layer
The Hardware Abstraction Layer (HAL) provides a view of the various hardware attached to a
system. This view is updated dynamically as hardware configuration changes by means of
hotplug or other mechanisms. HAL represents a piece of hardware as a device object. A
device object is identified by a unique identifer and carries a set of key/value pairs,
referred to as device properties. Some properties are derived from the actual hardware,
some are merged from device information files (.fdi files), and some are related to the
actual device configuration.
HAL provides an easy-to-use API through D-Bus. D-Bus is an IPC framework that, among other
features, provides a system-wide message-bus that allows applications to talk to one
another. Specifically, D-Bus provides asynchronous notification such that HAL can notify
other peers on the message-bus when devices are added and removed, as well as when proper-
ties on a device are changing.
In the Solaris operating system, HAL is supported by a daemon, hald(1M), and a set of
utilities that enable the adding and removing of devices and the modification of their
See the HAL pages, including the HAL specification, under http://freedesktop.org.
SunOS 5.11 11 Sep 2006 hal(5)
All times are GMT -4. The time now is 05:57 AM.