grub(5) Standards, Environments, and Macros grub(5)
grub - GRand Unified Bootloader software on Solaris
The current release of the Solaris operating system is shipped with the GRUB (GRand Uni-
fied Bootloader) software. GRUB is developed and supported by the Free Software Founda-
The overview for the GRUB Manual, accessible at www.gnu.org, describes GRUB:
Briefly, a boot loader is the first software program that runs when a computer starts. It
is responsible for loading and transferring control to an operating system kernel software
(such as Linux or GNU Mach). The kernel, in turn, initializes the rest of the operating
system (for example, a GNU [Ed. note: or Solaris] system).
GNU GRUB is a very powerful boot loader that can load a wide variety of free, as well as
proprietary, operating systems, by means of chain-loading. GRUB is designed to address the
complexity of booting a personal computer; both the program and this manual are tightly
bound to that computer platform, although porting to other platforms may be addressed in
the future. [Ed. note: Sun has ported GRUB to the Solaris operating system.]
One of the important features in GRUB is flexibility; GRUB understands filesystems and
kernel executable formats, so you can load an arbitrary operating system the way you like,
without recording the physical position of your kernel on the disk. Thus you can load the
kernel just by specifying its file name and the drive and partition where the kernel
Among Solaris machines, GRUB is supported on x86 platforms. The GRUB software that is
shipped with Solaris adds two utilities not present in the open-source distribution:
bootadm(1M) Enables you to manage the boot archive and make changes to the GRUB
installgrub(1M) Loads the boot program from disk.
Both of these utilities are described in Solaris man pages.
Beyond these two Solaris-specific utilities, the GRUB software is described in the GRUB
manual, a PDF version of which is available from the Sun web site. Available in the same
location is the grub(8) open-source man page. This man page describes the GRUB shell.
boot(1M), bootadm(1M), installgrub(1M)
Solaris Express Installation Guide: Basic Installations
System Administration Guide: Basic Administration
SunOS 5.11 21 Apr 2005 grub(5)