utmp(4) File Formats utmp(4)NAME
utmp, wtmp - utmp and wtmp database entry formats
The utmp and wtmp database files are obsolete and are no longer present on the system. They have been superseded by the extended database
contained in the utmpx and wtmpx database files. See utmpx(4).
It is possible for /var/adm/utmp to reappear on the system. This would most likely occur if a third party application that still uses utmp
recreates the file if it finds it missing. This file should not be allowed to remain on the system. The user should investigate to deter-
mine which application is recreating this file.
SEE ALSO utmpx(4)SunOS 5.11 22 Feb 1999 utmp(4)
Check Out this Related Man Page
utmpx(4) File Formats utmpx(4)NAME
utmpx, wtmpx - utmpx and wtmpx database entry formats
The utmpx and wtmpx files are extended database files that have superseded the obsolete utmp and wtmp database files.
The utmpx database contains user access and accounting information for commands such as who(1), write(1), and login(1). The wtmpx database
contains the history of user access and accounting information for the utmpx database.
Applications should not access these databases directly, but should use the functions described on the getutxent(3C) manual page to inter-
act with the utmpx and wtmpx databases to ensure that they are maintained consistently.
/var/adm/utmpx user access and adminstration information
/var/adm/wtmpx history of user access and adminstrative information
SEE ALSO getutxent(3C), wait(3C)wait.h(3HEAD)SunOS 5.10 22 Feb 1999 utmpx(4)
When I type last oracle I get dates from Nov 28, 2000 all the way back to the beginning of time it seems. The 11-28-2000 entry states that Oracle is still logged in, but if you type a who, it shows only 1 entry - the currently logged in user (Me as oracle), but I logged in only minutes ago - and... (4 Replies)
I just noticed by running a who command that I was logged in twice . So two admin2 are on the list. (solaris 2.6)
Since I telnet using a windows 98, I suppose that I forgot to CTRL-D last time I logged in and clicked on hangup.
In such a case, how can I loggoff the old ghost loggin ?
It's not a... (4 Replies)
Hi everybody I have a problem with wtmpx. Accounting file. I activated it. It works but to well :( Writes the same message every minute. "faxmodem" As you can see it does not take to long until my /var file is soon full.
Peter (26 Replies)
Hi, I just started working with UNIX on an old semi-fossilized Sun workstation which I use to process LOTS of images,however, I just started to get an error message that the file system is full and then my shell tool or/and text editor freeze up. Help? (8 Replies)
Platform sol 8
I had wtmpx growing very large(1.2 G). I copied the file and compressed it the did a "cat /dev/null > /var/adm/wtmpx" to zero out the file and not close any doors to any processes. (After searching this seemed like the right method)
This is a box that gets accessed from other... (5 Replies)
Do someone know how to delete entry(some lines)
in file "wtmpx" that command "last" use it.
this file is binary so I cannot edit directy.
root pts/1 noc Fri Mar 3 22:04 still logged in
root pts/1 noc Fri Mar 3 22:01 - 22:02 ... (4 Replies)
I am using Sun Solaris 5.9 OS. I have found a file called wtmpx having a size of 5.0 GB. I want to clear this file using :>/var/adm/wtmpx. My query is, would it cause any problem to the running live system.
Could anyone suggest the best method to clear the file without causing problem to... (6 Replies)
I have a problem with the file wtmp that is on /var/adm
This file was not on this directory (adm).
I try creating a new file with the correct rights (644) and owner (adm:adm)
but It doesnt work.
If I type the last command i get this
ora10g ... (4 Replies)
uname -a output
Linux server.domain.com 2.6.9-67.0.15.ELsmp #1 SMP Tue Apr 22 13:50:33 EDT 2008 i686 i686 i386 GNU/Linux
At our company, we have hundreds of employees that access this server for reporting purposes.
However, someone was familiar enough with sendmail and used it to send an... (8 Replies)
Hello All, On my SuSE system, I have wtmp log this log file permission is 644 but every reboot the file permission rollback to 664. In the logrotate.conf and logrotate.d/wtmp files the wtmp logrotate set to 644. I would like to know, which "file" or "script" modify the wtmp log to rollback to... (7 Replies)
I work on solaris 8, 9 and 10 platforms and have encountered an error which is my wtmpx files appear to be corrupted as all entries contain the date 1970 (the birth of unix).
Now this is obviously not the case, so my query is:
1 - Can the existing wtmpx files be manipulated to... (6 Replies)
First time post, so please be gentle. :)
I'm writing a Solaris 10 ksh script to retrieve details of logins and logouts using specific user names. The details I want are quite basic - the username, the computer logged in from, and the date and time the user logged in and logged off.... (6 Replies)
we have a solaris 10 box that was handled by a different sysadmin before & now it is turned over to us for system administration. our concern is that if we issue the "last" command, it usually says "wtmp begins current day current month date 02:30". just like this "wtmp begins Thu Mar 7... (6 Replies)
Anyone got experience where wtmp logs get truncated everyday? Though sulog, failedlogin and lastlog seems to be fine.
The server uptime is 18 days running on AIX 5.3. Sorry this seems to be a generic questions but never really encountered before. (6 Replies)