services(4) File Formats services(4)NAME
services - Internet services and aliases
The services file is a local source of information regarding each service available through the Internet. The services file can be used in
conjunction with or instead of other services sources, including the NIS maps "services.byname" and the NIS+ table "services." Programs
use the getservbyname(3SOCKET) routines to access this information.
The services file contains an entry for each service. Each entry has the form:
service-name port/protocol aliases
service-name This is the official Internet service name.
port/protocol This field is composed of the port number and protocol through which the service is provided, for instance, 512/tcp.
aliases This is a list of alternate names by which the service might be requested.
Fields can be separated by any number of SPACE and/or TAB characters. A number sign (#) indicates the beginning of a comment; any charac-
ters that follow the comment character up to the end of the line are not interpreted by routines which search the file.
Service names may contain any printable character other than a field delimiter, a NEWLINE, or a comment character.
Any changes to a port assignment do not affect the actual port registration of the service.
/etc/nsswitch.conf configuration file for name-service switch
SEE ALSO getservbyname(3SOCKET), inetd.conf(4), nsswitch.conf(4)NOTES
/etc/inet/services is the official SVR4 name of the services file. The symbolic link /etc/services exists for BSD compatibility.
SunOS 5.11 12 Oct 2000 services(4)
Check Out this Related Man Page
SERVICES(5) BSD File Formats Manual SERVICES(5)NAME
services -- service name data base
The services file contains information regarding the known services available in the DARPA Internet. For each service a single line should
be present with the following information:
official service name
Items are separated by any number of blanks and/or tab characters. The port number and protocol name are considered a single item; a ``/''
is used to separate the port and protocol (e.g. ``512/tcp''). A ``#'' indicates the beginning of a comment; subsequent characters up to the
end of the line are not interpreted by the routines which search the file.
Service names may contain any printable character other than a field delimiter, newline, or comment character.
INTERACTION WITH DIRECTORY SERVICES
Processes generally find service records using one of the getservent(3) family of functions, or using getaddrinfo(3). On Mac OS X, these
functions interact with the DirectoryService(8) daemon, which reads the /etc/services file as well as searching other directory information
services to determine service name, protocol, and port information.
SEE ALSO getservent(3), getaddrinfo(3), DirectoryService(8)HISTORY
The services file format appeared in 4.2BSD.
4.2 Berkeley Distribution June 5, 1993 4.2 Berkeley Distribution
When I scan my linux box for open ports, i have several of them, but they shouldn't be open. I removed the lines for them in /etc/services, and left just stuff like telnet, ssh, ftp. Why are they still open? I've restarted the network, and I've even restarted my box, but they still apear as open.... (4 Replies)
What are all the services/daemons we use in NFS configuration?
I know that nfs,portmap,nfslock the the services we use.But I am not sure that which service wil do what job? Is there any other services running for NFS?
What services are running on server side and what services are running in... (4 Replies)
Can anyone help me by telling how to open port 161 in solaris 10? I have added it in /etc/services but it is not working. I checked by telneting but I could not connect to that server on the port 161. I am trying to communicate using snmp services. (6 Replies)
I need assistance...
I need to open a port # 36677 and have it remain open even after a power cycle.
I thought all I needed to do was add it to /etc/services. That was not it...
Can someone please tell me how to do this.
Thank you. (6 Replies)
I'm writing a script that will automate the launch of some services on my AIX machine. However, some services are dependent on the successful startup of others. When I start these services manually, I usually just check a log file until I see a message that confirms a successful... (3 Replies)
According to security manual only DNS, files, or LDAP should be allowed in nsswitch file however it seems like i have many other services configured in nsswitch files.
below are the content from nsswitch file.
What services can be removed considering the system stability.
passwd: files... (6 Replies)
In my AIX 5.3 box I already have the below entry:
#cat /etc/services | grep -i 3602
infiniswitchcl 3602/tcp # InfiniSwitch Mgr Client
infiniswitchcl 3602/udp # InfiniSwitch Mgr Client
Now I got an requirement to add the below entry in the same port... (6 Replies)
I'm becoming a dying breed where I work. More and more sys admins are advocating automatically restarting failed services such as tomcat, jboss, etc. I've always been against doing this except with buggy apps that can't be fixed or avoided.
My main argument is that I feel it's a trick used by... (9 Replies)
I had a doubt if any services need to be restarted if port no in /etc/services in an RHEL setup is changed. For eg, the port no of 443 for SSL may need to be changed.
I hope my query is clear whether any services need to be restarted if port no in /etc/services is changed.
Please revert with... (10 Replies)
I would like to know wheather it is possible to enable same services on another Linux Box, which are enabled on First Linux Server.
Server A having some services enabled, I want same kind of services enabled on Server B using single command / using chkconfig command, instead... (4 Replies)
Good Morning All,
I'm a novice and please excuse me if i did miss some of the forum rules.
What my intention is, i have a file (services) residing @ /u01/Oracle/services.
I know i can use the find command to find the "service" file. I get this file from a windows box and there is no certain... (8 Replies)