remote(4) File Formats remote(4)
remote - remote host description file
The systems known by tip(1) and their attributes are stored in an ASCII file which is
structured somewhat like the termcap file. Each line in the file provides a description
for a single system. Fields are separated by a colon `:'. Lines ending in a `\' character
with an immediately following NEWLINE are continued on the next line.
The first entry is the name(s) of the host system. If there is more than one name for a
system, the names are separated by vertical bars. After the name of the system comes the
fields of the description. A field name followed by an `=' sign indicates a string value
follows. A field name followed by a `#' sign indicates a following numeric value.
Entries named tipbaudrate are used as default entries by tip, as follows. When tip is
invoked with only a phone number, it looks for an entry of the form tipbaudrate, where
baudrate is the baud rate with which the connection is to be made. For example, if the
connection is to be made at 300 baud, tip looks for an entry of the form tip300.
Capabilities are either strings (str), numbers (num), or boolean flags (bool). A string
capability is specified by capability=value; for example, `dv=/dev/harris'. A numeric
capability is specified by capability#value; for example, `xa#99'. A boolean capability is
specified by simply listing the capability.
at (str) Auto call unit type. The following lists valid 'at' types and their corre-
biz31f Bizcomp 1031, tone dialing
biz31w Bizcomp 1031, pulse dialing
biz22f Bizcomp 1022, tone dialing
biz22w Bizcomp 1022, pulse dialing
df02 DEC DF02
df03 DEC DF03
ventel Ventel 212+
v3451 Vadic 3451 Modem
v831 Vadic 831
hayes Any Hayes-compatible modem
at Any Hayes-compatible modem
br (num) The baud rate used in establishing a connection to the remote host. This is a
decimal number. The default baud rate is 300 baud.
cm (str) An initial connection message to be sent to the remote host. For example, if a
host is reached through a port selector, this might be set to the appropriate
sequence required to switch to the host.
cu (str) Call unit if making a phone call. Default is the same as the dv field.
db (bool) Cause tip(1) to ignore the first hangup it sees. db (dialback) allows the
user to remain in tip while the remote machine disconnects and places a call back to
the local machine. For more information about dialback configuration, see System
Administration Guide: IP Services.
di (str) Disconnect message sent to the host when a disconnect is requested by the
du (bool) This host is on a dial-up line.
dv (str) Device(s) to open to establish a connection. If this file refers to a terminal
line, tip attempts to perform an exclusive open on the device to insure only one
user at a time has access to the port.
ec (bool) Initialize the tip variable echocheck to on, so that tip will synchronize
with the remote host during file transfer by waiting for the echo of the last char-
el (str) Characters marking an end-of-line. The default is no characters. tip only
recognizes `~' escapes after one of the characters in el, or after a RETURN.
es (str) The command prefix (escape) character for tip.
et (num) Number of seconds to wait for an echo response when echo-check mode is on.
This is a decimal number. The default value is 10 seconds.
ex (str) Set of non-printable characters not to be discarded when scripting with beau-
tification turned on. The default value is "\t\n\b\f".
fo (str) Character used to force literal data transmission. The default value is
fs (num) Frame size for transfers. The default frame size is equal to 1024.
hd (bool) Initialize the tip variable halfduplex to on, so local echo should be per-
hf (bool) Initialize the tip variable hardwareflow to on, so hardware flow control is
ie (str) Input end-of-file marks. The default is a null string ("").
nb (bool) Initialize the tip variable beautify to off, so that unprintable characters
will not be discarded when scripting.
nt (bool) Initialize the tip variable tandem to off, so that XON/XOFF flow control
will not be used to throttle data from the remote host.
nv (bool) Initialize the tip variable verbose to off, so that verbose mode will be
oe (str) Output end-of-file string. The default is a null string (""). When tip is
transferring a file, this string is sent at end-of-file.
pa (str) The type of parity to use when sending data to the host. This may be one of
even, odd, none, zero (always set bit 8 to 0), one (always set bit 8 to 1). The
default is none.
pn (str) Telephone number(s) for this host. If the telephone number field contains an
`@' sign, tip searches the /etc/phones file for a list of telephone numbers -- see
phones(4). A `%' sign in the telephone number indicates a 5-second delay for the
For Hayes-compatible modems, if the telephone number starts with an 'S', the tele-
phone number string will be sent to the modem without the "DT", which allows recon-
figuration of the modem's S-registers and other parameters; for example, to disable
auto-answer: "pn=S0=0DT5551234"; or to also restrict the modem to return only the
basic result codes: "pn=S0=0X0DT5551234".
pr (str) Character that indicates end-of-line on the remote host. The default value is
ra (bool) Initialize the tip variable raise to on, so that lower case letters are
mapped to upper case before sending them to the remote host.
rc (str) Character that toggles case-mapping mode. The default value is `\377'.
re (str) The file in which to record session scripts. The default value is tip.record.
rw (bool) Initialize the tip variable rawftp to on, so that all characters will be sent
as is during file transfers.
sc (bool) Initialize the tip variable script to on, so that everything transmitted by
the remote host will be recorded.
tb (bool) Initialize the tip variable tabexpand to on, so that tabs will be expanded to
spaces during file transfers.
tc (str) Indicates that the list of capabilities is continued in the named description.
This is used primarily to share common capability information.
Example 1 Using the Capability Continuation Feature
Here is a short example showing the use of the capability continuation feature:
/etc/remote remote host description file.
/etc/phones remote host phone number database.
System Administration Guide: IP Services
SunOS 5.11 13 Jun 2002 remote(4)