queuedefs(4) File Formats queuedefs(4)
queuedefs - queue description file for at, batch, and cron
The queuedefs file describes the characteristics of the queues managed by cron(1M). Each
non-comment line in this file describes one queue. The format of the lines are as follows:
The fields in this line are:
q The name of the queue. a is the default queue for jobs started by at(1); b is the
default queue for jobs started by batch (see at(1)); c is the default queue for
jobs run from a crontab(1) file.
njob The maximum number of jobs that can be run simultaneously in that queue; if more
than njob jobs are ready to run, only the first njob jobs will be run, and the
others will be run as jobs that are currently running terminate. The default
value is 100.
nice The nice(1) value to give to all jobs in that queue that are not run with a user
ID of super-user. The default value is 2.
nwait The number of seconds to wait before rescheduling a job that was deferred because
more than njob jobs were running in that job's queue, or because the system-wide
limit of jobs executing has been reached. The default value is 60.
Lines beginning with # are comments, and are ignored.
Example 1 A sample file.
This file specifies that the a queue, for at jobs, can have up to 4 jobs running simulta-
neously; those jobs will be run with a nice value of 1. As no nwait value was given, if a
job cannot be run because too many other jobs are running cron will wait 60 seconds before
trying again to run it.
The b queue, for batch(1) jobs, can have up to 2 jobs running simultaneously; those jobs
will be run with a nice(1) value of 2. If a job cannot be run because too many other jobs
are running, cron(1M) will wait 90 seconds before trying again to run it. All other queues
can have up to 100 jobs running simultaneously; they will be run with a nice value of 2,
and if a job cannot be run because too many other jobs are running cron will wait 60 sec-
onds before trying again to run it.
/etc/cron.d/queuedefs queue description file for at, batch, and cron.
at(1), crontab(1), nice(1), cron(1M)
SunOS 5.11 1 Mar 1994 queuedefs(4)