|Linux & Unix Commands - Search Man Pages
networks(4) File Formats networks(4)
networks - network name database
The networks file is a local source of information regarding the networks which comprise
the Internet. The networks file can be used in conjunction with, or instead of, other
networks sources, including the NIS maps networks.byname and networks.byaddr and the
NIS+ table networks. Programs use the getnetbyname(3SOCKET) routines to access this infor-
The network file has a single line for each network, with the following information:
official-network-name network-number aliases
Items are separated by any number of SPACE or TAB characters. A `#' indicates the begin-
ning of a comment. Characters up to the end of the line are not interpreted by routines
which search the file. This file is normally created from the official network database
maintained at the Network Information Control Center (NIC), though local changes may be
required to bring it up to date regarding unofficial aliases and/or unknown networks.
Network numbers may be specified in the conventional dot (`.') notation using the
inet_network routine from the Internet address manipulation library, inet(7P). Network
names may contain any printable character other than a field delimiter, NEWLINE, or com-
getnetbyaddr(3SOCKET), getnetbyname(3SOCKET), inet(3SOCKET), nsswitch.conf(4), inet(7P)
The official SVR4 name of the networks file is /etc/inet/networks. The symbolic link
/etc/networks exists for BSD compatibility.
The network number in networks database is the host address shifted to the right by the
number of 0 bits in the address mask. For example, for the address 184.108.40.206 that has a
mask of fffffe00, its network number is 803351. This is obtained when the address is
shifted right by 9 bits. The address maps to 12.66.23. The trailing 0 bits should not be
specified. The network number here is different from that described in netmasks(4). For
this example, the entry in netmasks would be 220.127.116.11 fffffe00.
SunOS 5.11 17 Jan 2002 networks(4)
All times are GMT -4. The time now is 08:11 PM.