fd(4) File Formats fd(4)
fd - file descriptor files
These files, conventionally called /dev/fd/0, /dev/fd/1, /dev/fd/2, and so on, refer to
files accessible through file descriptors. If file descriptor n is open, these two system
calls have the same effect:
fd = open("/dev/fd/n",mode);
fd = dup(n);
On these files creat(2) is equivalent to open, and mode is ignored. As with dup, subse-
quent reads or writes on fd fail unless the original file descriptor allows the opera-
For convenience in referring to standard input, standard output, and standard error, an
additional set of names is provided: /dev/stdin is a synonym for /dev/fd/0, /dev/stdout
for /dev/fd/1, and /dev/stderr for /dev/fd/2.
creat(2), dup(2), open(2)
open(2) returns -1 and EBADF if the associated file descriptor is not open.
SunOS 5.11 3 Jul 1990 fd(4)