Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

soconfig(1m) [opensolaris man page]

soconfig(1M)						  System Administration Commands					      soconfig(1M)

NAME
soconfig - configure transport providers for use by sockets SYNOPSIS
/sbin/soconfig -f file /sbin/soconfig family type protocol [path] DESCRIPTION
The soconfig utility configures the transport provider driver for use with sockets. It specifies how the family, type, and protocol parame- ters in the socket(3SOCKET) call are mapped to the name of a transport provider such as /dev/tcp. This utility can be used to add an addi- tional mapping or remove a previous mapping. The init(1M) utility uses soconfig with the sock2path(4) file during the booting sequence. OPTIONS
The following options are supported: -f file Set up the soconfig configuration for each driver according to the information stored in file. A soconfig file consists of lines of at least the first three fields listed below, separated by spaces: family type protocol path These fields are described in the OPERANDS section below. An example of file can be found in the EXAMPLES section below. OPERANDS
The following operands are supported: family The protocol family as listed in the /usr/include/sys/socket.h file, expressed as an integer. type The socket type as listed in the /usr/include/sys/socket.h file, expressed as an integer. protocol The protocol number as specified in the family-specific include file, expressed as an integer. For example, for AF_INET this number is specified in /usr/include/netinet/in.h. An unspecified protocol number is denoted with the value zero. module | path The module name or path name of a device that corresponds to the transport provider, such as tcp or /dev/tcp. Modules must reside in kernel/socketmod. A device name must begin with /dev. If this parameter is specified, the configuration will be added for the specified family, type, and protocol. If this parameter is not specified, the configuration will be removed. EXAMPLES
Example 1 Using soconfig The following example sets up a module for family AF_INET and type SOCK_STREAM: example# soconfig 2 2 0 tcp The following example sets up /dev/tcp for family AF_INET and type SOCK_STREAM: example# soconfig 2 2 0 /dev/tcp The following is a sample file used with the -f option. Comment lines begin with a hash mark (#): # Family Type Protocol Module | Path 2 2 0 tcp 2 2 6 tcp 2 1 0 udp 2 1 17 udp 1 2 0 /dev/ticotsord 1 1 0 /dev/ticlts 2 4 0 icmp FILES
/etc/sock2path File containing mappings from sockets to transport providers. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsr | +-----------------------------+-----------------------------+ SEE ALSO
init(1M), sock2path(4), attributes(5) Network Interface Guide SunOS 5.11 29 Oct 2008 soconfig(1M)

Check Out this Related Man Page

socketpair(3SOCKET)					     Sockets Library Functions					       socketpair(3SOCKET)

NAME
socketpair - create a pair of connected sockets SYNOPSIS
cc [ flag ... ] file ... -lsocket -lnsl [ library ... ] #include <sys/types.h> #include <sys/socket.h> int socketpair(int domain, int type, int protocol, int sv[2]); DESCRIPTION
The socketpair() library call creates an unnamed pair of connected sockets in the specified address family domain, of the specified type, that uses the optionally specified protocol. The descriptors that are used in referencing the new sockets are returned in sv[0] and sv[1]. The two sockets are indistinguishable. RETURN VALUES
socketpair() returns -1 on failure and 0 on success. ERRORS
The call succeeds unless: EAFNOSUPPORT The specified address family is not supported on this machine. EMFILE Too many descriptors are in use by this process. ENOMEM There was insufficient user memory for the operation to complete. ENOSR There were insufficient STREAMS resources for the operation to complete. EOPNOTSUPP The specified protocol does not support creation of socket pairs. EPROTONOSUPPORT The specified protocol is not supported on this machine. EACCES The process does not have appropriate privileges. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |MT-Level |Safe | +-----------------------------+-----------------------------+ SEE ALSO
pipe(2), read(2), write(2), socket.h(3HEAD), attributes(5) NOTES
This call is currently implemented only for the AF_UNIX address family. SunOS 5.10 10 Jan 2001 socketpair(3SOCKET)
Man Page