kernel(1M) System Administration Commands kernel(1M)
kernel - UNIX system executable file containing basic operating system services
kernel-name [-asrvx] [-m smf_options] [-i altinit]
The operating system image, or kernel, is the collection of software comprising the image files (unix and genunix) and the modules loaded
at any instant in time. The system will not function without a kernel to control it.
The kernel is loaded by the boot(1M) command in a machine-specific way. The kernel may be loaded from disk, CD-ROM, or DVD (diskfull boot)
or over the network (diskless boot). In either case, the directories under /platform and /kernel must be readable and must contain exe-
cutable code which is able to perform the required kernel service. If the -a flag is given, the user is able to supply different pathnames
for the default locations of the kernel and modules. See boot(1M) for more information on loading a specific kernel.
The moddir variable contains a list of module directories separated by whitespace. moddir can be set in the /etc/system file. The minimal
/platform/platform-name/kernel /kernel /usr/kernel
This default can be supplemented by a specific platform. It is common for many SPARC systems to override the default path with:
where platform-name can be found using the -i option of uname(1), and hardware-class-name can be found using the -m option of uname(1).
The kernel configuration can be controlled using the /etc/system file (see system(4)).
genunix is the platform-independent component of the base kernel.
The following options are supported:
Asks the user for configuration information, such as where to find the system file, where to mount root, and even override the name of
the kernel itself. Default responses will be contained in square brackets ([ ]), and the user may simply enter RETURN to use the
default response (note that RETURN is labeled ENTER on some keyboards). To help repair a damaged /etc/system file, enter /dev/null at
the prompt that asks for the pathname of the system configuration file. See system(4).
Select an alternative executable to be the primordial process. altinit must be a valid path to an executable. The default primordial
process is init(1M).
The smf_options include two categories of options to control booting behavior of the service management facility: recovery options and
Message options determine the type and amount of messages that smf(5) displays during boot. Service options determine the services
which are used to boot the system.
Prints standard per-service output and all svc.startd messages to log.
Boot with some SMF services temporarily disabled, as indicated by milestone. milestone can be "none", "single-user", "multi-user",
"multi-user-server", or "all". See the milestone subcommand of svcadm(1M).
Prints standard per-service output and error messages requiring administrative intervention.
Prints standard per-service output with more informational messages.
Reconfiguration boot. The system will probe all attached hardware devices and configure the logical namespace in /dev. See add_drv(1M)
and rem_drv(1M) for additional information about maintaining device drivers.
Boots only to init level 's'. See init(1M).
Boots with verbose messages enabled. If this flag is not given, the messages are still printed, but the output is directed to the sys-
tem logfile. See syslogd(1M).
Does not boot in clustered mode. This option only has an effect when a version of Sun Cluster software that supports this option has
See boot(1M) for examples and instructions on how to boot.
Contains kernel components common to all platforms within a particular instruction set that are needed for booting the system. of the
core image file.
The platform-specific kernel components.
The kernel components specific to this hardware class.
Contains kernel components common to all platforms within a particular instruction set.
The directories in this section can potentially contain the following subdirectories:
Loadable device drivers
The modules that execute programs stored in various file formats.
File system modules
Miscellaneous system-related modules
Operating system schedulers
System V STREAMS loadable modules
Loadable system calls
Processor specific modules
Time-Of-Day hardware interface modules
As only 64-bit SPARC platforms are supported, all SPARC executable modules are contained within sparcv9 directories in the directories
x86 hardware support
Modules comprising the 32-bit x86 kernel are contained in the above directories, with the 64-bit x86 kernel components contained within
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Availability |SUNWcar, SUNWcarx |
uname(1), isainfo(1), add_drv(1M), boot(1M), init(1M), kadb(1M), rem_drv(1M), savecore(1M), svc.startd(1M), svcadm(1M), syslogd(1M), sys-
tem(4), attributes(5), smf(5), devfs(7FS)
The kernel gives various warnings and error messages. If the kernel detects an unrecoverable fault, it will panic or halt.
Reconfiguration boot will, by design, not remove /dev entries for some classes of devices that have been physically removed from the sys-
SunOS 5.11 27 Nov 2007 kernel(1M)