PUTTER(9) BSD Kernel Developer's Manual PUTTER(9)NAME
putter -- Pass-to-Userspace Transporter
The putter subsystem is used for request-response handling of userspace components. It currently provides routines for associating a file
descriptor with a subsystem data structure instance and I/O routines. Users of the facility must fill out the callbacks in struct putter_ops
to integrate with putter.
SEE ALSO pud(4), puffs(4)BUGS
Under construction. Interfaces may and will change.
BSD November 21, 2007 BSD
Check Out this Related Man Page
RUMP_CD9660(8) BSD System Manager's Manual RUMP_CD9660(8)NAME
rump_cd9660 -- mount a cd9660 image with a userspace server
rump_cd9660 [options] image mountpoint
NOTE! This manual page describes features specific to the rump(3) file server. Please see mount_cd9660(8) for a full description of the
available command line options.
The rump_cd9660 utility can be used to mount cd9660 file systems. It uses rump(3) and p2k(3) to facilitate running the file system as a
server in userspace. As opposed to mount_cd9660(8), rump_cd9660 does not use file system code within the kernel and therefore does not
require kernel support except puffs(4). Apart from a minor speed penalty there is no downside with respect to in-kernel code.
rump_cd9660 does not require using vnconfig(8) for mounts from regular files and the file path can be passed directly as the image parameter.
In fact, the use of vnconfig(8) is discouraged, since it is unable to properly deal with images on sparse files.
In case the image contains multiple partitions, the desired partition must be indicated by appending the token ``%DISKLABEL:p%'' to the image
path. The letter ``p'' specifies the partition as obtained via disklabel(8). For example, to mount partition ``e'' from image /tmp/wd0.img,
It is recommended that untrusted file system images be mounted with rump_cd9660 instead of mount_cd9660(8). Corrupt file system images com-
monly cause the file system to crash the entire kernel, but with rump_cd9660 only the userspace server process will dump core.
To use rump_cd9660 via mount(8), the flags -o rump and -t cd9660 should be given. Similarly, rump_cd9660 is used instead of mount_cd9660(8)
if ``rump'' is added to the options field of fstab(5).
SEE ALSO p2k(3), puffs(3), rump(3), mount_cd9660(8)HISTORY
The rump_cd9660 utility first appeared in NetBSD 5.0.
BSD November 21, 2010 BSD
Debian VPS running on proxmox host.
Linux ve2 2.6.18-3-pve #1 SMP Mon Sep 20 14:57:48 CEST 2010 i686
I have a most perplexing problem. I have 17 Drop rules in place in this VPS - and one of the banned ranges is making it through. (It happens to be a Googlebot).
Here is the... (5 Replies)
Good afternoon everyone,
It's the iptables n00b again. valiantly learning and reading (and asking for occasional help when I hit a wall - which I think I just did)
So far I've gotten logging enabled for iptables.
Now, I want to drop AND log an IP connection attempt.
Could some wise eyes... (2 Replies)
Here's the problem, I have a list generated by this command;
watch -n 5 'iptables -nvL | grep "DROP"'
It generates output that looks like this (severely truncated for clarity)
Every 5.0s: iptables -nvL | grep "DROP" ... (2 Replies)
I have a rather lengthy list of banned IP ranges in iptables. Initially it was constructed as a rather ad-hoc affair, then later I discovered a site which had IP Block By Country lists, and imported several into iptables.
If possible, I'd like to be able to verify if the list... (0 Replies)
Wondering how this could be accomplished........
a directory contains sequentially numbered files from fw01 to fw999.
How would I insert an additional zero so that the directory lists these files in a proper manner?
(i.e. all double digit files from fw01 to fw99 would become... (3 Replies)
Puttering around in unix, and read this in the mkdir man page:
"The mkdir utility creates the directories named as operands..."
What does this mean, i.e. as operands?
DN (2 Replies)
I'm looking to isolate the first occurrence of an arbitrary substring which may be present at any particular line in a given file. The enclosing end markers for the target in our thought problem are string" and ". The complete string and surrounding text could look something like... (3 Replies)
Sometimes it is necessary to run a job in the foreground that would normally be run as an overnight cron job.
When the job is run in the foreground, slightly different code may be required. Rather than having two scripts, I thought of following:
#!/bin/ksh ... (3 Replies)