|Linux & Unix Commands - Search Man Pages
PUFFS(4) BSD Kernel Interfaces Manual PUFFS(4)
puffs -- Pass-to-Userspace Framework File System
puffs provides a framework for creating file systems as userspace servers. The in-kernel
VFS attachment is controlled through a special device node, /dev/puffs. People looking to
implement file systems should use the system through the convenience library described in
A puffs file system can be unmounted regularly using umount(8). The file system will auto-
matically be unmounted in case the userspace server is killed or the control file descriptor
An unsupported experimental version of puffs first appeared in NetBSD 4.0. A stable version
appeared in NetBSD 5.0.
Antti Kantee <firstname.lastname@example.org>
BSD November 22, 2009 BSD
All times are GMT -4. The time now is 11:31 AM.