netbsd man page for mstohz

Query: mstohz

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

MSTOHZ(9)						   BSD Kernel Developer's Manual						 MSTOHZ(9)

NAME
mstohz, hztoms -- convert between milliseconds and system clock ticks
SYNOPSIS
#include <sys/param.h> int mstohz(int ms); int hztoms(int hz);
DESCRIPTION
The mstohz() macro can be used to convert time in milliseconds to system clock ticks, as used by the callout(9) facility, in an integer-over- flow safe way. Conversely, hztoms() converts system clock ticks to milliseconds. These macros are defined in the <sys/param.h> header. Individual ports can have a processor-specific, more efficient version implemented in their <machine/param.h> header as a define.
RETURN VALUES
The return value is either the number of clock ticks or milliseconds for the specified value.
SEE ALSO
param(3), callout(9), tvtohz(9)
BUGS
Neither mstohz() nor hztoms() make use of expensive 64-bit integer arithmetic. The result from mstohz() will be rounded down to one second if the parameter is larger than 131072 milliseconds.
BSD
October 20, 2011 BSD
Related Man Pages
drv_usectohz(9f) - debian
drv_usectohz(9f) - osf1
drv_usectohz(9f) - suse
drv_usectohz(9f) - osx
drv_usectohz(9f) - xfree86
Similar Topics in the Unix Linux Community
Unix File Permissions
Memory Leaks
How to install PGX32 on Sparc 10 Ultra?
Make bold chars in UNIX
BSD Unix Toolbox: 1000+ Commands for FreeBSD, OpenBSD, and NetBSD