YPSET(8) BSD System Manager's Manual YPSET(8)NAME
ypset -- tell ypbind(8) which NIS server process to use
ypset [-h host] [-d domain] server
ypset tells the ypbind(8) process on the current machine which NIS server process to communicate with. If server is down or is not running a
NIS server process, it is not discovered until a NIS client process attempts to access a NIS map, at which time ypbind(8) tests the binding
and takes appropriate action.
ypset is most useful for binding a NIS client that is not on the same broadcast network as the closest NIS server, but can also be used for
debugging a local network's NIS configuration, testing specific NIS client programs, or binding to a specific server when there are many
servers on the local network supplying NIS maps.
The options are as follows:
Set the NIS binding on host instead of the local machine.
Use the NIS domain domain instead of the default domain as returned by domainname(1).
SEE ALSO domainname(1), ypcat(1), ypmatch(1), ypwhich(1), nis(8), ypbind(8), yppoll(8)AUTHORS
Theo de Raadt
BSD February 26, 2005 BSD
Check Out this Related Man Page
ypset(8) System Manager's Manual ypset(8)NAME
ypset - bind ypbind to a particular NIS server
ypset [ -d domain ] [ -h hostname ] server
In order to run ypset, ypbind must be initiated with the -ypset or -ypsetme options. See ypbind(8). ypset tells ypbind to get NIS ser-
vices for the specified domain from the ypserv(8) process running on server.
In cases where several hosts on the local net are supplying NIS services, it is possible for ypbind to rebind to another host even while
you attempt to find out if the ypset operation succeeded. For example, you can type:
example% ypset host1
which can be confusing. This is a function of the NIS subsystem's attempt to know always a running NIS server, and occurs when host1 does
not respond to ypbind because it is not running ypserv (or is overloaded), and host2, running ypserv, gets the binding.
Server indicates the NIS server to bind to, and must be specified as a name or an IP address. This will work only if the node has a cur-
rent valid binding for the domain in question, and ypbind has been set to allow use of ypset. In most cases, server should be specified
as an IP address.
OPTIONS -d domain
Specify a domain other than the default domain as returned by domainname(8).
Set the NIS binding on host hostname
instead of the local machine.
SEE ALSO domainname(8), ypbind(8), ypcat(8), ypmatch(1), ypserv(8), yppoll(8), ypwhich(1)AUTHOR
ypset is part of the yp-tools package, which was written by Thorsten Kukuk <firstname.lastname@example.org>.
YP Tools 2.14 April 2010 ypset(8)
:eek: hi all,
I have a NIS trouble on a server.
when I create a file on a server (server1), the group of this file is the number of the group and not its name.
when I create a file with this group on another server which depends of another NIS slave, the file is created with the group name.... (10 Replies)
I have a query in relation to a couple of machines I have set up. We will call them machine SUN and HPUX and they are running those operating systems respectively. The SUN machine is acting as an NIS server and the HPUX machine as an NIS client. Now the HPUX machine also has a an auto mounted file... (11 Replies)
I recentely aquired an old B1000 workstation running HP-UX 11(I think) that was a member of a NIS domain. As such it now fails to find it's domain, that lab has been dismantled, this is however not a huge problem by it's self but what is a problem is that all of the libs and bins were stored in a... (8 Replies)
I have purchased a Dec unix Ver 3.2c machine that is about ten years old. I need to get this machine on our network (windows 2003 domain) so I can copy files to it. I know I need to change the IP address, but where and how do I change it? What else do I chang?
Thanks Randy (8 Replies)
I have a 44P-170 (7044-170) machine that has 4.3 ML11 installed on it and I am having a problem with NFS/NIS at boot. The machine will boot all the way up to the CDE login screen but when I log in as root, the screen goes black and will stay that way overnight. I have tried a console login as... (24 Replies)
I want to know whether i can change the password of a user logged in thru NIS from a client machine after stopping the YP services in NIS server.
Note - The Slave server is up and running.
I tried doing this. But i got the reply "Permission Denied".
I stopped the YP services in... (7 Replies)
I have a trouble with configure NIS Client on AIX, my NIS server is on a Linux machine.
After configure, some old NIS account could login normally. However, after I create new account from NIS server, I could not login with the new account, but could only su to that account. And I could view... (20 Replies)
I configured NIS on my Centos 5.5.
I create accounts on NIS Server and users can log in. Cool.
Now I added a user in my sudoers users in my NIS Server but user on other Linux boxes don't get the sudo permissions
any way or procedure to integrate sudo in a NIS setup?
thanks a... (14 Replies)
I have solaris-11 global and multiple non-global zones running, which all are on same network. They are not in NIS. When we open putty session and give user-name, it takes long time in asking password (around 40-50 seconds) on Global zone. While on non-global zones, it is working... (9 Replies)
We have a process on our Linux RedHat machine creating symbolic links and moving around some files from domain to domain. The issue is that the programmer has left a long time ago and nobody knows how the program is called, where it is and how the scheduling is setup. It runs every day for... (7 Replies)
So I have created two Centos machines. One is configured as a NIS master and the second is a NIS cleint. The NIS configs are all working perfectly.
I created a user nisuser on NIS Master and I can use it on the client. BUT it doesnt show a home directory . Ive been told there is... (9 Replies)
I have a Solaris 10 SPARC server that crashed a couple of weeks ago and I finally got it up the other day. I am having some problems getting my NIS automounts to work though. It appears that NIS is working, but the /home directories are not mounting and users can not log in (I can log... (6 Replies)
Hopefully someone can help.
We have a process that writes a file using Connect Direct to our local Solaris server and then our C++ program will pick up the file and process it. Unfortunately, because of the size of the file, the C++ program is processing the file before it has finished... (7 Replies)