NIS(8) BSD System Manager's Manual NIS(8)
nis, yp -- description of the NIS (formerly YP) subsystem
ypset [-h host] [-d domain] server
yppoll [-h host] [-d domain] mapname
ypcat [-kt] [-d domainname] mapname
ypmatch [-kt] [-d domainname] key ... mapname
ypwhich [-d domain] [[-t] -m [mname] | host]
ypserv [-d] [-x]
yppush [-d domainname] [-h hostname] [-v] mapname
ypxfr [-bcf] [-d domain] [-h host] [-s domain] [-C tid prog ipadd port] mapname
ypinit -m [domainname]
ypinit -s master_server [domainname]
rpc.yppasswdd [-noshell] [-nogecos] [-nopw] [-m arg1 arg2 ...]
The NIS subsystem allows network management of passwd and group file entries through the
functions getpwent(3) and getgrent(3). NIS also provides hooks for other client programs,
such as amd(8) and rpc.bootparamd(8), that can use NIS maps.
Password maps in standard YP are insecure, because the pw_passwd field is accessible by any
user. A common solution to this is to generate a secure map (using ``makedbm -s'') which can
only be accessed by a client bound to a privileged port. To activate the secure map, see
the appropriate comment in /var/yp/Makefile.yp.
The NIS subsystem is conditionally started in /etc/rc. See the /etc/rc.conf file for con-
domainname(1), ypcat(1), ypmatch(1), ypwhich(1), ypclnt(3), group(5), hosts_access(5),
nsswitch.conf(5), passwd(5), rc.conf(5), rc(8), ypbind(8), ypinit(8), yppoll(8), yppush(8),
ypserv(8), ypset(8), yptest(8), ypxfr(8)
The NIS client subsystem was originally written by Theo de Raadt to be compatible with Sun's
implementation. The NIS server suite was originally written by Mats O Jansson.
If ypbind(8) cannot find a server, the system behaves the same way as Sun's code: it hangs.
The 'secure map' feature is not compatible with non-BSD implementations as found e.g. in
BSD February 26, 2005 BSD