SETOBJSTAT(8) BSD System Manager's Manual SETOBJSTAT(8)NAME
setobjstat -- set SCSI Environmental Services Device object status
setobjstat device objectid stat0 stat1 stat2 stat3
setobjstat sets the object status for a SCSI Environmental Services (or SAF-TE) device. The objectid argument may be determined by running
The status fields are partially common (first byte only, which must have a value of 0x80 contained in it), but otherwise quite device spe-
cific. A complete discussion of the possible values is impractical here. Please refer to the ANSI SCSI specification (available on the FTP
Note that devices may simply and silently ignore the setting of these values.
/dev/sesN SCSI Environmental Services Devices
SEE ALSO ses(4), getencstat(8), sesd(8), setencstat(8)BSD February 21, 2000 BSD
Check Out this Related Man Page
SES(4) BSD Kernel Interfaces Manual SES(4)NAME
ses -- SCSI Environmental Services driver
The ses driver provides support for all SCSI devices of the environmental services class that are attached to the system through a supported
SCSI Host Adapter, as well as emulated support for SAF-TE (SCSI Accessible Fault Tolerant Enclosures). The environmental services class gen-
erally are enclosure devices that provide environmental information such as number of power supplies (and state), temperature, device slots,
and so on.
A SCSI Host adapter must also be separately configured into the system before a SCSI Environmental Services device can be configured.
It is only necessary to explicitly configure one ses device; data structures are dynamically allocated as devices are found on the SCSI bus.
A separate option, SES_ENABLE_PASSTHROUGH, may be specified to allow the ses driver to perform functions on devices of other classes that
claim to also support ses functionality.
The following ioctl(2) calls apply to ses devices. They are defined in the header file <cam/scsi/scsi_ses.h> (q.v.).
SESIOC_GETNOBJ Used to find out how many ses objects are driven by this particular device instance.
SESIOC_GETOBJMAP Read, from the kernel, an array of SES objects which contains the object identifier, which subenclosure it is in, and the
ses type of the object.
SESIOC_GETENCSTAT Get the overall enclosure status.
SESIOC_SETENCSTAT Set the overall enclosure status.
SESIOC_GETOBJSTAT Get the status of a particular object.
SESIOC_SETOBJSTAT Set the status of a particular object.
SESIOC_GETTEXT Get the associated help text for an object (not yet implemented). ses devices often have descriptive text for an object
which can tell you things like location (e.g., "left power supply").
SESIOC_INIT Initialize the enclosure.
The files contained in <usr/share/examples/ses> show simple mechanisms for how to use these interfaces, as well as a very stupid simple moni-
/dev/sesN The Nth SES device.
When the kernel is configured with DEBUG enabled, the first open to an SES device will spit out overall enclosure parameters to the console.
The ses driver was written for the CAM SCSI subsystem by Matthew Jacob. This is a functional equivalent of a similar driver available in
Solaris, Release 7.
BSD January 29, 2000 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)