|Linux & Unix Commands - Search Man Pages
FLASHCTL(8) BSD System Manager's Manual FLASHCTL(8)
flashctl -- a program to manipulate flash devices
flashctl device command [arg [...]]
flashctl could be used to invoke low level operations specific to flash devices. It is used
by specifying a device to manipulate, the command to perform, and any arguments the command
The following commands may be used on flash devices:
badblocks List the bad blocks on the device.
erase offset size Erase size amount of flash memory from offset. Size could be all, which
means the rest of the flash after offset will be erased.
identify Identify the specified device, displaying the device's vendor, product
strings, and the device's capabilities.
markbad offset Mark the block given by its offset as bad.
The flashctl command first appeared in NetBSD 6.0.
The flashctl command was written by Adam Hoka.
BSD February 27, 2011 BSD
All times are GMT -4. The time now is 07:59 AM.