FLASH(4) BSD Kernel Interfaces Manual FLASH(4)NAME
flash -- device-independent flash layer
The flash driver provides a device-independent interface for using flash memory.
The following ioctl(2) operations are supported on /dev/flash:
FLASH_BLOCK_ISBAD (struct flash_badblock_params)
This command checks if a block is marked as bad.
FLASH_BLOCK_MARKBAD (struct flash_badblock_params)
This command marks a block as bad.
FLASH_DUMP (struct flash_dump_params)
This command dumps a block.
FLASH_ERASE_BLOCK (struct flash_erase_params)
This command erases one or more blocks.
FLASH_GET_INFO (struct flash_info_params)
This command aquires information aboout the flash device.
SEE ALSO flash(9), nand(9)AUTHORS
Adam Hoka <ahoka@NetBSD.org>
BSD January 21, 2010 BSD
Check Out this Related Man Page
M16C-FLASH(1) General Commands Manual M16C-FLASH(1)NAME
m16c-flash - Flash programmer for Renesas M16C and R8C microcontrollers
m16c-flash [COM_DEV] [CPU_TYPE] [FILE] [ID1:...:ID7] [OPTIONS]
m16c-flash is a flash programmer for the Renesas M16C and R8C microcontrollers which operates in asynchronous mode.
COM_DEV The serial device to use for flashing, e.g. /dev/ttyS0 or /dev/ttyUSB0.
CPU_TYPE The CPU type you want to flash to (currently M16C or R8C).
FILE The filename of the binary you want to flash.
ID1:...:ID7 The device ID.
--help Show a help text and exit.
--version Show version information and exit.
Flash the simple.s file onto an M16C microcontroller via the first serial port (/dev/ttyS0) using 0:0:0:0:0:0:0 as the device ID:
m16c-flash /dev/ttyS0 M16C simple.s 0:0:0:0:0:0:0
Flash the test.mot file onto an R8C microcontroller via the USB serial device /dev/ttyUSB0, and using ff:ff:ff:ff:ff:ff:ff as device ID:
m16c-flash /dev/ttyUSB0 R8C test.mot ff:ff:ff:ff:ff:ff:ff
Please report any bugs to Thomas Fischl <email@example.com>.
m16c-flash is covered by the GNU General Public License (GPL).
Greg Reynolds <firstname.lastname@example.org>
Jim Hawkridge <email@example.com>
Thomas Fischl <firstname.lastname@example.org>
This manual page was written by Uwe Hermann <email@example.com>, for the Debian GNU/Linux system (but may be used by others).
August 20, 2006 M16C-FLASH(1)
Well, someone created a flash intro for us (their first attempt at SWiSH!)
Notice it says "Search before posting a question".....
Well????... (24 Replies)
Discussion started by: Neo
3. Post Here to Contact Site Administrators and Moderators
As everyone might know by now, we have a new 'draft' banner with matrix theme, falling unix commands, blinking numbers, and more. This will be the new default theme for the forums.
We are in the process of sending final comments to our designer, please feel free to post your suggestions here.... (20 Replies)
Discussion started by: Neo
4. Post Here to Contact Site Administrators and Moderators
Im using Redhat Linux enterprise editon 4.0
When ever i open firefox, i get a msg saying that "Install missing plugins"
When i click that macromedi flash player is downloaded.
And after i install flash player also, in fireforx i get the same message
Pls help me (11 Replies)
on a daily / hourly basis I need need to check the size for the Flash Recovery Area (v$flash_recovery_area_usage)
I was not in work yesterday and when I arrived today I checked the alert log only to find that the usage was 100%. This means the overnight backups will not run.
I... (12 Replies)
At first I have to say that I know nothing about Linux :(
But I am looking for solution how to copy one file from internal Lowrnace HDS flash memory.
Lowrance HDS is Linux based device.
Here is the link for firmware update files for this unit.
At the end of main firmware file there... (62 Replies)
I'm working as sys admin on a db server that's currently serviced by 30x 15k disks and is getting about 3000-3500 iops. A consultant has suggested we can replace that with 10x 10k disks and 700g of flash. He has not performed any testing to determine the working set, growth patterns, etc... and I... (11 Replies)
I have a .dmg file which was created from a disk consisting of two partitions. When I mount the dmg both partitions pop up, so I know the imaging worked properly. One partition is HFS+ and the other is FAT32.
So far, I've been unable to find a way to restore the dmg to a flash drive where both... (17 Replies)